IP Control of Amp - Looking for solutions

thanks @thebearmay ! I am going to test it and report back!

Feedback:

  1. Set Input still not working. Under "current states" on the device screen, it does correctly show the input selected or set, but somehow, it's not been executed on the amp. It also shows a lastParseMessage of -e.1. For instance, if I set the input to 1, the current states shows "balanced" and lastParseMessage -e.1. Perhaps an issue with the format of the message ?

  2. After installing the new driver update, I had to click on "connect telnet" to get things to start working. Does this code allow for maintaining the telnet connection? Because I am still experiencing that occasional nothing works scenario.

  3. Also, though the Send Msg works when I use it to change the input, the correct input is not shown under "current states". Example, if i set the input to -i.4 ( coaxial ), it works ok, but current states still show whatever the previous input was. I suspect this is related to #1 above.

Seems we are almost there !

The e.1 in the parse message is an error code, so it doesn’t like something I’m sending. Telnet connections should have a built-in keep alive, so not sure what the occassional pause is about unless it’s processing an error. If you use the manual send the driver doesn’t know what was sent so it will get out of sync; i.e. good for debugging but shouldn’t be needed for everyday use. The On command should do a Telnet Connect prior to sending the power on.

Edit: Think I found the issue with the input command. v0.1.6 should fix.

Happy to report set input is working ! changes all inputs and correctly reports the selected input under current states!

However, the same cannot be said for the Send Msg button - it correctly processes all messages, including changing inputs with -i.x BUT the current states of the input is not changed! Thats about the only thing left!

Yeah, right now the Send Message is a unmonitored/unfiltered back door direct to the amp. I’ll look at what can be done to try and keep the states in sync, might be a day or 2.

No problem at all! Whenever you can get to it! So now, I can use RM to setup the logic i wanted? something along the lines of:

  1. At 6 am , check if the amp is on, if not, turn it on and switch input source to #1
  2. At 6.30 am switch to input source #4
  3. At 8 am, power off amp
  4. Send connection reset every 2 minutes to keep connection alive

Can i set the default input to 1 after every power on?

V0.1.7 adds:

  • option for a starting default input, 0 to use last value, 1-9 to set
  • option to have the driver automatically send the -r.3 every 2 minutes.

So if you set the preferences your above becomes:

  1. At 6 am , check if the amp is on, if not, turn it on
  2. At 6.30 am switch to input source #4
  3. At 8 am, power off amp
1 Like

@thebearmay this is great . Thank you! Here is the current state of the union. I will know if its working on monday. Will report back then. but testing the actions seems to work. Wonderful learning experience for me. Going to sift through the driver code to understand it and attempt it on another amp ( Yamaha ) . I see there are other drivers for amps like denon, marantz and onkyo but not yamaha. Its not a priority for me but will look at this to learn what I can do there too. Many thanks!! Beer offer stands!.

ps: ignore the error messages from the current states. these are from previous attempts to get it to work. its not refreshed.



1 Like

@thebearmay Something is still not right with the telnet connection. My rule did not run this morning. I had also setup a dashboard with buttons for some of the actions. The buttons works great - tested it extensively yesterday. This morning, the buttons were all unresponsive. Only after I clicked on "Connect Telnet" did they start working again. Do you think we need to issue a "Connect Telnet" with every custom command ?

Did the parse message have any “e” messages in it? (May need to look at the event history.)

@thebearmay Here is a view of the event history for the relevant time period. As you can see from my rule above, I have it turn on ( if its off ) at 5.58 am and switch to input 4 ( coax). Then at 6.30 switch to input 1 ( balanced xlr). Then turn it off at 8.30 am. Seems the events registered ok? But the telnet connection didn't seem to work . Maybe I will monitor it another day or two and see what happens.

In the meantime, I have modified my rules like below to see if it works tomorrow

Would have been great to have device debug logging and descriptive text logging options.

Was hoping the connection was sending back a message that it had been dropped so that we could react to that, but since it isn't we'll have to assume that it has been dropped and attempt to reconnect every time. No real harm, just extra traffic and a small delay.

v0.1.8 is out with the option to re-establish the connection every time a command is issued.

@thebearmay tried version 0.18. this seems to have killed the telnet connection entirely. Even clicks on the buttons in the device setup screen don't work now.

Should be able to get back to the prior functionality by turning off the "Re-establish Connection with each Command" switch.

Yep that worked.

v0.1.10 - adds the state sync when using the sendMsg, removes the force connect from v0.1.8, and traps the “receive error: Stream is closed” message for an auto-reconnect

@thebearmay When I applied the latest version, the buttons on the dashboard started working immediately. They were all responsive. Then after a minute or so, went back to the unresponsive state. I tried various commands directly from the device setup screen, and got this:

#### Current States

* input : **Coaxial**
* lastMessage : **java.net.ConnectException: Connection refused (Connection refused)**
* lastParseMessage : **-**
* lastStatusMessage : **-**
* lastVolume : **27**
* mute : **off**
* networkStatus : **online**
* switch : **on**

But worked again after I manually clicked on the connect telnet button. Perhaps, I need to wait a bit between sending commands. I will continue to test and report back. Many Thanks!

Got this from the logs:

Error is a typo on my part, fixed.

1 Like

No error messages now in the logs with dashboard button pushes! Will conitnue to monitor and report back. Many thanks!!

2 Likes

Download the Hubitat app