iOS Geofence Presence keeps going in and out when home

I'm running into a problem with one of the family members iPhone's (6s) and the geofence feature. It will continually go in and out of "Present" and "Not Present" at night when not using his phone. We increased the geofence to the maximum size thinking that the precision of his location wasn't as accurate while the phone with sleeping.

The weird thing is another family member has an iPhone 6s and that one works perfectly. Keeping the correct presence state when home.

Just wanted to see if anyone else was experiencing this issue or what may be causing it.

1 Like

I am (was). The issue has stopped as of yesterday. :crossed_fingers:

My events were much more rapid than yours though. Had to disable mode changes. I'd still argue that a built in presence delay would go a long way to fix this.

Ahh! Great idea about the delay. Didn't even think of that, not sure why. :man_shrugging:

I'll give that a go!

1 Like

Is there a way to go about this? I can't seem to figure the logic out...

Here is an easy example. You could add if/thens for day/night away modes.

My preference would be that this is built into Mode Manager

This happened to me also with other platform and after much tweaking I realized the problem was that while I was indoors the GPS of my IOS device was slightly off, not much but enough to trigger the presence detection.

An easy way to check is, when you are having this problem (hubitat reporting on and off site) go to the maps app in the IOS device and see where are you located. In my case, I was a few blocks off site. Moving around a bit with the phone solved the issue, but in many cases it was really inconsistent.

While not a solution per se, at least when I realized this I stopped looking for problems in the platform. They delay option looks like a good solution.

Download the Hubitat app