iOS App - Duplicate presence devices

Gotcha! I think I have had that happen once or twice as well. I think I killed the app and tried again. Maybe I even rebooted my phone? Or maybe I deleted the app and reinstalled it? Can't recall. Definitely some room for improvement!

I am a little leery of iOS 13.0 at this time. I may wait until 13.1 is released... :thinking:

1 Like

I figured out a way to get to the "select devices" after the app loads. By going to the "select hub" page from settings, I can choose my (only) hub, then choose a mobile device. The app doesn't hang, and now it's back to the original virtual device, so I can delete the duplicate.

2 Likes

Nice workaround! Thanks for sharing.

1 Like

I’m running into a similar issue again, this time with a twist.

My mobile presence device somehow became unlinked with my phone last night, resulting in duplicate presence devices in hubitat. But this time when I try to switch to the correct presence device in the mobile app, I get this screen instead of the list of mobile devices associated with my hub:

So now the workaround I described above doesn’t help. I can create new (duplicate) presence devices, but I can’t select any previously created devices in the Mobile app because it thinks my hub has no presence devices...

I’m using the latest mobile app beta on my iPhone XS running iOS 13.1.2. Deleting the app and reinstalling through TestFlight doesn’t seem to have made a difference.

@patrick or @chuck.schwer any suggestions about how I can get the mobile app to re-populate the list of presence devices associated with my hub?

1 Like

I had this happen recently... IIRC, I was able to get the list of devices to populate by turning off WiFi on my phone while at home, and used the cellular LTE data connection. This allowed the list of devices to populate, and then select the correct one.

I also noticed recently that I cannot get the list of existing devices to show up when using my iPAD. I have not tried connecting my iPAD on a different network yet.

@chuck.schwer, any idea if there is a bug when trying to connect the Mobile App to a hub that is on the same network?

1 Like

That's what it sounds like. I'll pass this along to our mobile app developer.

3 Likes

Argh, that seemed like a good plan, but I’m still seeing the “we couldn’t find any mobile presence devices” message even when I’m connecting through 4G.

@chuck.schwer do you know what else I can try to get the app to “see” my mobile presence devices so that it doesn’t keep creating a new one?

I've been experiencing these issues for a while now... IN addition, there appears to be a bug in the app that keeps repeating notifications and messing up presence status... For the last several days, I keep getting multiple messages that I or another phone in my family has arrived, only to be followed by that person has left a few minutes later... I got so annoyed last night, I logged out of the app, deleted it and tried re-installing... Of course, I was presented with the "hanging" loading mobile devices message which eventually just stopped and created a new device...

Then I had to go through all my rules and such to replace my old device with the new one...

I do think this could have something to do with IOS 13... No proof of that, just a hunch.

I'm having a similar problem as SMR06. If I log out of the IOS app on my iPhone XR and then log back in, another device with the same name is created in the Hubitat device list. If I log out and then log in again, no third iPhone device is created. I can delete both of these iPhone devices and "start over" as you suggested, but then all of my notification apps have to be re-coded because the phone disappears from the device notification list.

Logging out of an IOS app is a common procedure on an iPhone. I don't understand why the problem exists.

Don

I've posted previously that I am seeing the same iPhone issue as you. I've done some more research and here's what I have found.

I have a Motorola Moto G6 phone running Android and I'm not seeing ANY problems with duplicate devices. Also, notification seems to working working fine on the Moto, but has started working sporadically on my iPhone. When I log out and log back in with the Moto, I am given a choice to choose an existing mobile app device or create a new one. I'm not offered that choice on the iPhone.

I have a newer iPad mini. I don't create a duplicate device when I log out and log back into the app. But I also do not get to choose an existing mobile device. Both the iPad and iPhone are running IOS 13.1.3. But the iPad is showing slightly different behavior ( no duplicate device).

This sure looks like an IOS related BUG.

Don

2 Likes

@ogiewon and @chuck.schwer I’m not sure what changed, but I tried disconnecting from WiFi again, and when I logged back into the hubitat app, I was able to see the list of mobile devices. Now the app’s connection to the correct mobile presence device has been restored, and I deleted the duplicates.

Thanks for the suggestion, Dan!

Tonight my iPad was able to display a list of existing Mobile App devices from my hub with no issue.

However, my iPhone is unable to display the list of existing Mobile App devices from my hub, whether connected to WiFi or LTE networks.