[iOS 1.2.8:141] Registered hubs wrong IP shown in header

@moncho1138 I noticed in the "Registered hubs" section it shows the incorrect IP of 192.0.0.1 under the name of the hub (Home in my case). On the web portal is correctly shows 192.168.1.4.

If I select "Hub Details" it shows the correct IP, and also selecting the "Connect to Hub" takes me to the correct IP. So the app knows the IP it is just not showing it on the first page.

The web portal showing correct IP:
image

This shows incorrect IP in the app:

1 Like

Confirmed, will be fixed on the next build.

Thanks!

1 Like

This is fixed

2 Likes

@moncho1138,
This has also happened to me. The hub is over two hundred miles from me. Does this mean someone has to actually go to that location and physically update the OS on my hub before this can be fixed?

If the problem is the mobile app (which is what the thread title suggests) then when the new phone app is pushed to your phone it will correct itself; i.e. not an issue with the hub.

2 Likes

Thanks for the reply.

The problem is more than just a phone app. I can no longer see both of my hubs as registered hubs, even from my computer web browser.

The issue here is that your hubs are no longer connected to Hubitat's cloud. This could happen for many reasons, for eg. loss of internet connectivity.

Another reason that pops up frequently is when hubs are given a static IP without a proper DNS configuration. As such, they are unable to resolve the name(s) of Hubitat's cloud server(s) to IP addresses they can connect to.

4 Likes

And the easiest solution to this is to switch the hub to DHCP and set the static IP reservation on the router unless there is some reason you cannot do this.

3 Likes

@aaiyar, thanks for the reply.

I think your suggestion of DNS confusion makes sense.

I was using DHCP, but then things went bad after I shut down my equipment to untangle a bunch of wires. When I powered everything back up, the Hub was assigned a different IP address, which caused a cascade of bad events.

The first thing that happened was the "registered hub" list showed the wrong address for the hub in question (I have two hubs at two different locations). I tried rebooting the hub and rebooting the router to no avail. Then I decided to change the setting in the hub to a fixed IP address. I prefer using fixed IP addresses for things like hubs and printers because it seems to save me trouble down the line.

After rebooting the hub and the router with the fixed IP address, things got worse. I could find the hub locally only by directing my browser at the specific IP address of the hub. I could not locate the hub with the "search for hubs" tool on the app. Worse, the hub dropped off from my list of "registered hubs." Unfortunately, at that point I ran out of time and had to leave the property (250 miles from where I am now).

I was hoping I would be able to resolve this problem remotely, alas.

I thought DNS settings were resolved by the router for all attached devices. How would I resolve this DNS configuration for the hub specifically? Is there a place to set that in the HUB? I would be grateful for any help.

Settings > Network Setup.
Same place you set the static IP.
You can specify the router IP for the DNS there if you want, but the recommendation seems to be to set some others as well for backup.

Tip: use multiple DNS servers run by well known providers, for example 8.8.8.8, 8.8.4.4, 1.1.1.1, 1.0.0.1, 9.9.9.9

3 Likes

Download the Hubitat app