Inovelli Red Child Device Override

Hello all, I have my Inovelli Red switches hooked up and working. I have Child Devices created for the LED strips and am able to change colour, however, the intensity setting seems to be locked into whatever the Parent Device has set. Changing the intensity on the Child device has no effect. Is there any way to disable the Parent Device's control over the Child Device's intensity?

I am just setting the color on the parent device and it seems to work ok.

Hi, what are those paperclips in the rule? I'm not familiar with writing rules this way, but am now a little intrigued.

Here is what my rule looks like for my LED notification.

I use the paper clip emoji in the device name to indicate that it’s a hub meshed device. On my other hub I use a chain link emoji. I think I got the idea from @danabw but I could be wrong. Nice thing is an emoji doesn’t upset Alexa.

And you taught me something. I didn’t know you could set the leds that way. I am using numbers from the inovelli color tool. That way you can also use the chase/blink/fade etc as well.

So what function are you using to set your LEDs? I see it says Set LED notification, but I can't find function. (function may be the wrong word)

It’s under

Set modes, variables or files, run custom action

Run custom action

Capability = dimmer

Select red series dimmer

Then start notification

And you can add a number parameter

You can just put in an integer or a variable

1 Like

This may be helpful.
Here is the link to the Inovelli Switch Toolbox which allows you to get values for the LED configuration. (Note: there are three 'tabs' that can be used 'LED', 'NOTIFICATIONS', and 'SCENES' depending on the type of device you have).
You can also create an LED child device that you can configure directly instead of having to use the presets on the default child devices. This is done by enabling the 'Create "LED Color" Child Device' within the parent device driver.
Inovelli Switch Toolbox (


@JNS @steve.maddigan, thank you both. This was hugely helpful.

I don't think I would have figured out those number strings on my own.

1 Like

I think the only issue I'm having with the Child Device method is that I can't control the LED Intensity that way.

1 Like

Funny enough however, even with a string in Parameter 16 (notifications), my LED intensity seems to be stuck at 100%.

Even tough both Parameters 14 & 15 are both at 2 & 1. Despite this, the LED bar on the switch is at 100%.

Anyone else run into this?

I've tried power-cycling the switch.

Try creating a rule in RM that just sets the LED bar for the device.
Here are two values to test with (You can get these values from the link I posted above from the Notifications 'tab')
Red solid 100% - 33491709
Red solid 20% - 33489661
Create the following rule and then click 'Run Actions' the light bar should change to solid red at 20%. Then edit the rule to use the red solid 100% value and see if the LED changes. If it doesn't you may have an issue with the driver or device.
In my examples the 'Front Entry Scene Controller..." is the parent device not one of the child devices.

Here is a snapshot of the configuration settings

Side note: I upgraded the other day to beta FW 1.53 and my red notifications are now white.

I see that the inovelli tool states 1.48. I think I grabbed the RED numbers from the left side of the color slide. I guess I’ll have to grab from the right.

Side note # two. The white looks really nice.

Ok, I'm not seeing where I'm going wrong. Tried the suggested test and unfortunately, I can still not control the intensity of the LEDs. I've tried doing this with the built in Child devices as well as with using the number strings,

The LED bar is not being used by anything else, so no conflicts, This is happening with both Inovelli Red Dimmers so it must be the driver I am using, although I am sure I have the latest one. Can someone post their driver and I'll swap them out to see if that fixes it?

These are the drivers I am using.

Inovelli Dimmer Red Series LZW31-SN (Driver code)
Inovelli Switch Red Series LZW30-SN (Driver code)

I am running firmware version: 1.48 on the LZW31-SN and: 1.19 on the LZW30-SN.

I forgot to mention I am using the inovelli drivers that are available through HPM

1 Like

The links I posted were also installed via HPM. I initially installed them manually and then matched them when I installed HPM. At least I think that's what I did. It's been a while.

1 Like

Lol. I never hit you links :slight_smile: I thought you were just listing FW.

1 Like

I could see why you would think that. I updated my post to be more precise. :confused:

1 Like

Nope, ok didn't work, but let me explain what I am seeing.

Ok, sorry, trouble shooting as I'm writing this. So the string I am getting from Inovelli Switch Toolbox is not translating the correct way on my end.

For example; 33489232 should produce Color 80 (Green), Brightness 1, and Solid Notification Forever.

But instead, of brightness 1, its outputting brightness of about 5.

My firmware IS 1.48 according to the display on Hubitat. I can play with the numbers and get the intensity down, but I don't really understand how the strings work, so it's hard for me to pinpoint an accurate number.

Basically the lowest brightness level on any colour is only about 40 or 50%.

Can anyone else confirm?

I just did some testing and I see a distinct difference between each brightness setting. I'm not sure how to help you beyond what I suggested. You may want to reach out to Inovelli support.

  • Green, brightness 1, forever, solid - 33489232
  • Green, brightness 2, forever, solid - 33489488
  • Green, brightness 5, forever, solid - 33490256
1 Like