Inovelli LZW45 Lighstrip: White LED's?

Hi all,
I just received my Lightstrips for my Kitchen renovation under cabinet lighting. They paired easily and I'm using the Inovelli driver. It's a little confusing. I've read all of the posts both here and the Inovelli site. I want to start simply. In Rule machine I started a rule for button 1 of my Zooz Zen34 button device to turn on the strip at 50% warm white. That worked, mostly but instead of the warm white LED's lighting, the RGB led was used. Why? I have also tried cool white with the same result. I also tried calling a temperature instead and it also used the RGB LED. Any ideas would be greatly appreciated.

I've not tried to automate my Inovelli strips myself. However I would guess there is a Custom attribute to control the different LED types.

How are you controlling them in your current setup?

In rule machine I chose "Toggle Color Temperature and Level" on button press

Since I started this topic I tried my second light strip and it is using the while LED's with the same rule. The first strip only uses the RGB diode.

Try to see if the LEDStrip driver has a custom attribute that can allow you to choose what LEDs will be controlled.

will look when I get home from work

I don't see a custom attribute that you choose what LEDs will be controlled but I was able to get the strip to change from RGB mode to CT mode by cycling through all of the pixel effects. My rule is changing the color temp but it is turning the strip on and off like I expected. Will need to think about this a bit.
Thanks for your suggestion.

Not sure if this is helpful, but I was playing around with one of these these afternoon using Inovelli's driver. I kept getting an error in my log when running the setColorTemperature() command:

[error] java.lang.NullPointerException: Cannot get property 'level' on null object on line 925 (setColorTemperature)

I was able to make it work in what I think was the expected way by replacing value.level with device.currentValue("level") on the affected line (I don't see a value objected defined anywhere...), though a BasicSet to just turn it on should also work if that works and isn't a bad idea (I seem to recall 700-series certified Z-Wave requirements say something about this?).

Anyway, I guess my takeaway is: check your logs for errors. :slight_smile: If that doesn't explain it, the other thing I noticed is that Rule Machine's "Set Color" action uses RGBW mode even if you choose "Soft White" (hue 11, saturation 20--not color temperature mode). But it sounds like you're using the "Set Color Temperature" or "Toggle Color Temperature" action, which should use CT mode and--after the above adjustment--did in my testing.

@bertabcd1234,

Thank you so much! That is the error I was getting and the change you suggested worked.

I've never done any coding so I'm not sure what you mean by BasicSet

I did also see that in RuleMachine set color uses RGBW that's why I went with Toggle CT.

Can't you use set color temp to in Rule Machine to set the CT value? I am sure I missed something here, since Toggle CT is for dashboards as best I can tell.

Set CT and level did not work either until I implemented @bertabcd1234 's suggestion.

If the strip is not already on, setting color temperature from rule machine or motion lighting does not work properly. I raised the issue here and on the inovelli forums without a resolution. I tried the change above and am still getting the error in the logs.

I'm not getting any errors but now the level is not setting properly but the Color Temperature changes appropriately

With the setColorTemperature() command? If so, maybe try replacing that affected line (925?) with something like this instead of what I suggested above:

cmds << zwave.basicV1.basicSet(value: 0xFF)

This should just turn it on if it's off (and have no effect if it's already on) rather than relying on the last level it reported to Hubitat.

1 Like

That fixed it! Thank you so much!

Download the Hubitat app