Inovelli LZW30-SN Pending

Im new to Hubitat and having problem getting this switch to connect. I was using it on Samsung but it would stay connected about a day then never connect again.

Now, i attempt to connect to Hubitat using SmartStart and after doing a dance and spinning on my head i finally got some sort of connection but i now see 3 devices (same) and all say pending. Nothing in the DEVICES section - Just in the TOOLS I submitted a ticket with 'tech support' but havent seen any response so im hoping to get assistance here.

I added the following device driver

Inovelli Switch Red Series

  • Author: Eric Maycock (erocm123)
  • Date: 2021-05-25

Factory Reset the device a few times and finally got the blinking blue light and scanned the QR Code.

Ok..i uploaded an image and tried to embed a link to an image and am unable to do either..l pfft. I'm having great luck with this product.

Any advice is appreciated

Have you updated the firmware on this? I'm not sure what ira shopping with nowadays, but the original production version had problems with secure pairing (Z-Wave S2, which SmartStart will use). If you aren't sure or don't want to update, you can try pairing without security, but you'll have to do it manually (without SmartStart, from Devices > Add Device in the admin UI). When prompted, uncheck all boxes (which will be for S0 and S2 security).

Also try to remove the non-functional nodes from Settings > Z-Wave Details. Many people have reported problems if "ghosts" remain after a failed pairing.

Are you asking about firmware for Hubitat or Inovelli.

Hubitat is: 2.2.7.126 Rev Rev C-7

Not sure how i would find the Inovelli firmware version if i cant connect to it. I will try to connect manually as you suggest and get back. Thanks.

I mean the Inovelli switch firmware. You'd need a different Z-Wave controller to update the firmware if you can't connect it to Hubitat (Z-Wave PC Controller with any of various USB Z-Wave sticks is a popular choice; Inovelli has instructions on their site), but if you're able to get it paired without security (or with--I've had both this switch and a C-7 since their early days and it worked if I tried enough times...), you could update the firmware if you're still interested in trying that (or using S2).

I suggest you start over. As bertabcd1234 said.

I would:

  1. Reset the LZW30 on/off switch. Hold the program button for 20 seconds. I think the LED does a dance but I don't recall the sequence.

  2. Get rid of the existing references to any LZW30's . I.e. ghosts etc.

  3. Reboot the hub. Not sure why but it can't hurt.

  4. Repair the LZW30 manually with no security.

  5. I would initially use the generic Z_Wave on/off switch for initial testing.

I've also found being close to the hub helps.

Good luck.

ok just found out i cant reply thru email..

Thanks I will try the reset again and do a manual config if I can figure out where all these numbers come from :pensive: seems to be many more spaces for numbers than what is on the package. the hub is about 10 feet from this particular device . I will report back here in the next couple days as I get a chance to do this.

If you uncheck all security options, you should not be prompted for any numbers. But if you do use S2, that is normal and should be found on the code printed on the switch and the paper inside the box--basically, an alternative to the QR code. You'll only need the first five, which will sometimes be printed more prominently than the rest of the code (though I can't remember what Inovelli's looks like off the top of my head).

ok i think ive done as instructed but nothing yet. So let me summarize:

  1. I've reset the LZW30 Switch (twice for good luck)
  2. I've ensured all pending entries for this device have been removed from the hub.
  3. I've rebooted the hub and power cycled as well.
  4. My attempt to MANUALLY REPAIR is as follows:
    a. I selected 'Discover Devices'
    b. I tapped on LZW30 3 times for BLUE light (also tried a/b in reverse order)
    c. Discovery process times out after ~60 seconds.
  5. Ive tried this numerous times to no avail.
  6. Attempted to do another SmartStart sequence - this time i only got ONE pending notice. i attempted to edit this by Deselecting the s2 checkboxes and entering a name manually for the device but unable to SAVE.

ANy other advice?

It's odd that this doesn't work, but it sounds like your best chance until you can either update the firmware (I assume it isn't) or just to use indefinitely if you don't need Z-Wave S2.

One thing that might help here: do a Z-Wave Exclude (same page, different button) before you try the pairing/inclusion. A reset of the switch should take care of that (some vendors are weird here, but I don't think Inovelli is one), but it can't hurt, and it might help. I think your best hope is getting it to pair here, unchecking all boxes (no S2 or S0), and either using it that way or taking this as an opportunity to update the firmware.

I'd also recommend keeping "Logs" open when you do this. If you see a message like "Z-Wave network responded with Busy message," I'd recommend shutting down the hub--not restarting--and leaving it off and unplugged for about 30 seconds or so, then restarting. This will also restart the Z-Wave radio, which a normal restart won't. (Also shouldn't be necessary and it's suppose to automatically restart nowadays if it crashes, but it can't hurt to try once or twice if you need to...)

If none of this helps, you might try reaching out to Inovelli support. I'd mention that you're using a C-7 Hubitat and aren't sure what firmware version your LZW30-SN has or if it might be causing your pairing troubles (maybe they can verify what it's shipping with nowadays or help you get it updated outside of Hubitat?).

This is all i get from the logs.

sys:12021-06-11 12:01:27.878 pm Z-Wave Inclusion timed out, status:7
sys:12021-06-11 12:00:27.860 pm Z-Wave Discovery Running
sys:12021-06-11 12:00:24.930 pm Z-Wave Inclusion timed out, status:7
sys:12021-06-11 12:00:24.914 pm Z-Wave Discovery Stopped
sys:12021-06-11 12:00:23.961 pm Z-Wave Inclusion timed out, status:7
sys:12021-06-11 11:59:23.903 am Z-Wave Discovery Running
sys:12021-06-10 05:00:19.773 pm Z-Wave Inclusion timed out, status:7
sys:12021-06-10 04:59:19.739 pm Z-Wave Discovery Running
sys:12021-06-10 04:59:18.961 pm Z-Wave Inclusion timed out, status:7
sys:12021-06-10 04:59:18.947 pm Z-Wave Discovery Stopped
sys:12021-06-10 04:59:17.953 pm Z-Wave Discovery Running
sys:12021-06-10 04:58:54.122 pm Z-Wave Inclusion timed out, status:7
sys:12021-06-10 04:58:54.050 pm Z-Wave Discovery Stopped
sys:12021-06-10 04:58:15.355 pm Z-Wave Discovery Running

Ive ordered a Z-Wave + (Zooz) USB stick for my PC so i can try to check firmware. Wont be here for a while tho :frowning:

Nothing alarming there that I see. That's good, at least! Did you try an exclusion before pairing again? (That being said, the stick should also help you get this up to date, which is probably a good idea regardless.)

How do i exclude a device that isnt listed?

Put the hub in to exlcusion mode and put the device into learn/program mode.

Yep--just press the exclusion button instead of the inclusion button on Hubitat, and tap the config button on the Inovelli 3 times (same as inclusion). This will make sure the device doesn't think it's paired with a hub, as it won't try if it already thinks it is. Again, a reset should take care of this too, but a general exclusion (as this is called--not choosing a specific node to remove) can't hurt and is easy enough (especially compared to holding that button down for 20+ seconds to reset!).

oh yea..well that i did of course. i thought you meant there was another manual way. I didnt really get any feedback saying it was successful probably because the device never really joined.

Anyway, i suppose i will just wait for the USB Stick to get here and check the firmware. Thanks for all your assistance and i will report back when i have further info.

I have some other device questions but i will start another thread if i cant figure it out.

ok i got the USB ZWave Stick (Zooz S2) and plugged it in my laptop. Im guessing im supposed to add it to Hubitat first? i put hubitat in discover mode and plugged in the s2 stick but i get nothing when i attempt Z-Wave inclusion. AM i missing something or doing something wrong. I dont see any way to directly connect to the Inovelli switch either. .

You'll want to read this:

You can follow the above if you're having trouble removing "ghost nodes" created by failed pairing attempts, but you don't really need the stick paired to Hubitat to update firmware. The stick plus Z-Wave PC Controller can act as its own controller, entirely separate from Hubitat, and you can pair it to the stick just to update firmware, then remove it (or reset the stick and switch) and put it back on Hubitat.

Inovelli has instructions on how to use this software to update their firmware here:

well its finally attached. NO time at the moment to config automations but i will get around to it soon. I had to add it, remove it, manually set it to FAIL and then remove it again. Then add it again. Got the firmware updated. Tried the Smartstart again and got the Same pending message :frowning: then tried adding it using the dashboard Device Discovery -> Start Inclusion and that worked! Phew. What a goat rope really. This shouldn't be this difficult. Anyway, thanks a million for all of your advice and assistance. I wouldve likely given up if it wasnt for you guys.

Still some other things to figure out when i have time. Then to migrate the rest of my stuff away from SmartTHings.

Oh, i guess i can delete that PENDING device?? sheez.. hope that doesnt break anything else. lol.

Download the Hubitat app