Inovelli fan/light switch

I just installed this switch, and it seems that I can control the fan and lights, but looking at the log file for the device, I see these errors every hour:

dev:1192021-03-08 06:16:14.934 errorjava.lang.NumberFormatException: null (parse)

dev:1192021-03-08 06:16:14.885 debugSupervision Get - SessionID: 55, CC: 50, Command: 2

dev:1192021-03-08 06:16:14.882 debugparse:zw device: 0A, command: 6C01, payload: 37 08 32 02 21 34 00 00 00 09 , isMulticast: false

dev:1192021-03-08 06:16:14.727 infoOffice Fan energy is 0.794kWh

dev:1192021-03-08 06:16:14.721 debugMeter Report - meterType: 1, rateType: 1, scale: 0, scaledMeterValue: 0.794

dev:1192021-03-08 06:16:14.676 debugSupervision Get - SessionID: 54, CC: 50, Command: 2

dev:1192021-03-08 06:16:14.649 debugparse:zw device: 0A, command: 6C01, payload: 36 0E 32 02 21 64 00 00 03 1A 00 00 00 00 00 00 , isMulticast: false

dev:1192021-03-08 05:16:27.713 infoOffice Fan energy is 0.793kWh

dev:1192021-03-08 05:16:27.704 debugMeter Report - meterType: 1, rateType: 1, scale: 0, scaledMeterValue: 0.793

dev:1192021-03-08 05:16:27.696 debugSupervision Get - SessionID: 53, CC: 50, Command: 2

dev:1192021-03-08 05:16:27.692 debugparse:zw device: 0A, command: 6C01, payload: 35 0E 32 02 21 64 00 00 03 19 00 00 00 00 00 00 , isMulticast: false

dev:1192021-03-08 05:16:27.351 errorjava.lang.NumberFormatException: null (parse)

dev:1192021-03-08 05:16:27.260 debugSupervision Get - SessionID: 52, CC: 50, Command: 2

dev:1192021-03-08 05:16:27.189 debugparse:zw device: 0A, command: 6C01, payload: 34 08 32 02 21 34 00 00 00 04 , isMulticast: false

dev:1192021-03-08 04:16:40.309 errorjava.lang.NumberFormatException: null (parse)

dev:1192021-03-08 04:16:40.259 debugSupervision Get - SessionID: 51, CC: 50, Command: 2

dev:1192021-03-08 04:16:40.254 debugparse:zw device: 0A, command: 6C01, payload: 33 08 32 02 21 34 00 00 00 09 , isMulticast: false

dev:1192021-03-08 04:16:40.024 infoOffice Fan energy is 0.792kWh

dev:1192021-03-08 04:16:40.019 debugMeter Report - meterType: 1, rateType: 1, scale: 0, scaledMeterValue: 0.792

dev:1192021-03-08 04:16:39.974 debugSupervision Get - SessionID: 50, CC: 50, Command: 2

dev:1192021-03-08 04:16:39.905 debugparse:zw device: 0A, command: 6C01, payload: 32 0E 32 02 21 64 00 00 03 18 00 00 00 00 00 00 , isMulticast: false

dev:1192021-03-08 03:16:53.559 errorjava.lang.NumberFormatException: null (parse)

dev:1192021-03-08 03:16:53.508 debugSupervision Get - SessionID: 49, CC: 50, Command: 2

dev:1192021-03-08 03:16:53.504 debugparse:zw device: 0A, command: 6C01, payload: 31 08 32 02 21 34 00 00 00 04 , isMulticast: false

dev:1192021-03-08 03:16:53.238 infoOffice Fan energy is 0.791kWh

dev:1192021-03-08 03:16:53.232 debugMeter Report - meterType: 1, rateType: 1, scale: 0, scaledMeterValue: 0.791

dev:1192021-03-08 03:16:53.188 debugSupervision Get - SessionID: 48, CC: 50, Command: 2

dev:1192021-03-08 03:16:53.120 debugparse:zw device: 0A, command: 6C01, payload: 30 0E 32 02 21 64 00 00 03 17 00 00 00 00 00 00 , isMulticast: false

Is this a problem? I'm using the HE driver....should I update something?

I'd suggest grabbing Inovelli's driver and trying it.
(https://raw.githubusercontent.com/InovelliUSA/Hubitat/master/Drivers/inovelli-fan-light-lzw36.src/inovelli-fan-light-lzw36.groovy)

Yes, I just installed their driver and it certainly looks a lot different. Now I only see the following "debug" log entries:

dev:1192021-03-08 14:19:19.447 debugOffice Fan: MeterReport(meterType: 1, precision: 1, scale: 2, size: 4, meterValue: [], rateType: 1, deltaTime: 0, previousMeterValue: [])

dev:1192021-03-08 14:19:17.407 infoOffice Fan: Switch MultiLevel report received with value of off - ep2

dev:1192021-03-08 14:19:17.406 debugOffice Fan: SwitchMultilevelReport(value:0) - ep2

dev:1192021-03-08 14:19:17.400 debugOffice Fan: MultiChannelCmdEncap(bitAddress:false, command:1, commandClass:108, destinationEndPoint:0, parameter:[36, 3, 38, 3, 0], res01:false, sourceEndPoint:2)

Did you click the Config button after you changed drivers? It's about 4 rows down

1 Like

No, I didn't. I just did.

It gave me a firmware report: 1.34

Have the log messages stopped?

Upgrade to firmware 1.36 ASAP! Until you do, disable energy reporting in the switch settings. There is a major bug in 1.34 that causes the switch to disconnect from the canopy module or lock up completely under certain conditions related to energy usage reporting.....

OK, I'll update the firmware.

I get two errors every hour:

dev:1192021-03-08 16:13:51.792 debugOffice Fan: MeterReport(meterType: 1, precision: 3, scale: 0, size: 4, meterValue: [0, 0, 3, 177], rateType: 1, deltaTime: 0, previousMeterValue: [0, 0, 3, 136])

dev:1192021-03-08 16:13:51.226 debugOffice Fan: MeterReport(meterType: 1, precision: 1, scale: 2, size: 4, meterValue: [], rateType: 1, deltaTime: 0, previousMeterValue: [])

dev:1192021-03-08 15:14:07.930 debugOffice Fan: MeterReport(meterType: 1, precision: 3, scale: 0, size: 4, meterValue: [0, 0, 3, 155], rateType: 1, deltaTime: 0, previousMeterValue: [0, 0, 3, 136])

dev:1192021-03-08 15:14:07.403 debugOffice Fan: MeterReport(meterType: 1, precision: 1, scale: 2, size: 4, meterValue: [], rateType: 1, deltaTime: 0, previousMeterValue: [])

Do you still get them once debug reporting is disabled in the driver?

There are two switches right above the Save Preferences button if you’re lookign for them.

Not sure. I'm trying to update the firmware, but it says that I need to wake up my sleepy device. I tried to push the air-gap button but that didn't do anything.

Can I use the Firmware File Manager to do the update instead of the Z-Wave Firmware Updater?

I found the answer on the Inovelli site. Basically you have to exclude the device, then include it again and uncheck all of the security options. Once it's included without security, you can go ahead and update the firmware.

2 Likes

Download the Hubitat app