Inovelli Dual Z-Wave Plug (NZW37) will not include

I have a C-5 hub and am trying to add my Inovelli Dual Z-Wave Plug (NZW37) without any luck. I have tried to do the exclude from Hubitat also with no luck. I have an Aeotec Z-stick gen 5, and with it I am able to to the exclude and even an include with it. But I am not able to get the Inovelli plug to be recognized by my hub. Does anyone have any suggestions?

Thanks in advance.

1 Like

If it won't exclude, it won't include either.

  • How far away from the hub are you when trying to pair?
  • Did you try moving the device close to the hub to pair?
  • Have you previously successfully paired Z-wave devices to the hub?
  • Any messages in Logs tab while trying to pair?

The plug and hub are in the same room, only a couple feet apart. I successfully paired it to the hub back in 2019 when I started testing Hubitat, but I have been on SmartThings for years. I have not looked at the logs while trying to pair, but will look now.

Turn off the Smartthings hub if possible. It could be interfering with or overriding the pairing.

Try moving the hub really close to the device; that has helped me in the past.

1 Like

I powered off my SmartThings hub and still cannot get the plug to pair with my Hubitat hub. The two are only a foot apart. Yet, my Aeotec Z-Stick gen 5 will pair immediately with the plug if I turn it on. Seems like an issue with the Hubitat to me. It's running the latest firmware. Idk if I can obtain and apply older firmware to see if I can get it to work.

You can roll back firmware somewhat, any options you have are in the :8081 Diagnostics menu. I doubt this is a firmware issue though, the C5 has received no updates to how Z-wave works in years.

Do you have another device you can try to pair? Is this just isolated to this plug brand/model, or is it with all Z-wave pairing?

Well, after using the diagnostics menu to roll back to a previous version (which still wouldn't pair) and then rolling forward to the latest again, now my hub won't even power on. I've tried a few different power supplies and nothing. I guess it's time for me to give up on this hub.

What color is the light on the hub? Is is possible the hub changed IP addresses, and you can't access it at the location it was at previous? It would be quite unusual for the hub to die from rolling back. Maybe we need to have support look at this.

It still begs the question whether it was this particular device, or Z-wave in general that wasn't working. I don't suppose you tried a different Z-wave device?

The LED doesn't light up at all on the hub. I tried several other power supplies and still no light. Because the hub stopped working, I was unable to try adding other z-wave devices.

Lets tag @bobbyD and see if he can help.

Well, the power issue is from plugging and unplugging the micro USB cord in too many times. The solder connections to the circuit board lifted and broke. So in the trash it goes. Thanks all for trying to help.

FYI, this is fixable.

1 Like