Inovelli dimmer strobing

Going to get lazy, and cut & paste to repost from the Inovelli forums, where no-one has had any solid ideas just yet. The model number mentioned is a z-wave dimmer:

-begin copy-

I’ve got a LZW31, running under Hubitat, which I’ve been using for some time now. (I am using the custom driver instead of the generic Hubitat driver.) I have dimmable LED bulbs, which easily meet the required load. I do not have a neutral wire.

When I first installed it under Nexia, I got some occasional strobing. When I moved to Hubitat, that went away. It has recently started up again, and it is now impossible to use the light without strobing. Just to see if it could be related to the bulbs, I put some incandescent bulbs in- with no change to the constant strobing.

-end copy-

I should mention here I also tried using the stock Hubitat driver, with no change in results.

Any ideas? Thanks very much!

Is there an update to the switch firmware?

1 Like

I think the key here is "no neutral". It's odd that the issue persisted with incandencent bulbs, but with LEDs, you will need a bypass.


It has worked without a bypass in the past. The dimmer has specific instructions (which I followed) for setup without a bypass. It must have bulbs meeting a certain load level, which I have exceeded. (The company founder even chimed in on an early issue with the installation documentation, and he saw no problem with using it with LED and no neutral.)

The ability to use it with no neutral wire was actually one of the big reasons I selected this specific dimmer.

Not that I can find. If I can get a firmware update, I will have to figure out how to install it. It is just ZW, not ZW+, so not sure what impact that will have.

I have 30 some Inovelli switches in my home and experienced a similar issue with non compatible LEDs. Unfortunately, I have no experience with non neutral set-up. Someone else might be able to chime in if they encountered similar problems. I can tell you, that we did not have any similar reports from other users.

1 Like

Aren't all Inovelli, even the early ones, ZW+? This NZW is plus, for example.

What firmware are yours? You should be able to find it at the bottom of the Device's setting page. And are these LZW31-SN or just LZW31?

Here is the list of firmware where you can see if you are on the latest.

But to me, this sounds a lot like the GE/Jasco that were having capacitor issues. They also were having switches that would freak out and do odd stuff.

I have three inovelli red dimmers and one is installed with no neutral. I have not experienced any strobing. I am using it with a single 14” round led fixture from Home Depot and I do have a bypass on it.

I am attaching a screen pic of the FW I am running. You need to update both endpoints. I will try to find the link.


I will have to go back and look at hat all the documentation that came with it, but I am pretty darn sure Z-Wave plus is not listed on it anywhere. And it is definitely just 31, not the 31-SN.

Interesting. I will get in and look at the configuration again, but I'm pretty sure there is no listing for the firmware anywhere on the device settings. Of course, I could be wrong. I just don't remember seeing it anywhere at all.

EDIT: I just looked at the device page, and it will tell me what firmware I'm running (1.35), but gives me no way to update it.

He is showing the Firmware Update app.

It should be as shown below too. This is a Zooz, but should be similar for your switch.

And ZW vs ZW+ doesn't matter. Both can be firmware updated. In this case though, they are ZW+.

1 Like

Go to Apps tab.
Install a Built-In app button.
select Device Firmware Updater

From there, the documentation walks you through things. Device Firmware Updater - Hubitat Documentation

1 Like

Awesome. Thanks. I got the impression the firmware update would be part of the device page. I will definitely give that a look.

Yes I was showing the device updater page and yes I have the -SN which denotes the red dimmer I believe.

Sorry I only have this version plus one fan switch (and I really wish I had a second one of those)

1 Like

Posting my response from our community here just in case (I just posted, sorry for the delay):

"Looks like you’re getting some traction in the Hubitat forums and that was going to be my next suggestion outside of sending a replacement.

I think it was just a coincidence that it fixed itself when originally switching to Hubitat as there’s no way I can think of that a hub could impact strobing or not.

Here is what I’d recommend in the following order:

  • Remove the switch from Hubitat
  • Hold the config button down for 20 seconds to factory reset the switch
  • Pair to Hubitat
  • Set the AC Power Type to: Non-Neutral
  • Pull the air-gap and push it back in
  • Try to control your lights

If that doesn’t work, then update the firmware using the built in Hubitat Firmware Updater. I can’t access it at work bc I have a C4 where it’s not available, but off the top of my head you go to Apps and then add a Hubitat App and search for Firmware Updater or something like that.

Download the latest files from here: Index of /firmware/LZW31

The latest production version is 1.57 (Index of /firmware/LZW31/1.57). Download the 1.44.bin and 1.57.otz. The .bin file is Target 1 and the .otz is Target 0.

The app is pretty straight forward once you start it – it should walk you through it.

If that doesn’t work, then you can try changing the bulbs. It’s possible either the bulbs or switch has gone bad. Here is a compatibility app you can use: Resources | Compatible Bulb & Fan List (App)

Lastly, we can certainly change the switch out."



Thanks very much for your quite thorough response. In the past, you have done a bang-up job of helping me out with my issues!

A firmware update is definitely on my list. I'm a little bit ashamed to say that having used Hubitat for more than a year, I didn't realize there was a separate firmware updater app, and have never tried to update firmware on anything. It has been a learning process coming from a different platform which didn't require having to... You know... Actually know anything. :slight_smile: I've found I prefer having to figure things out, and have more knowledge about how they work- even if the process can sometimes cause a few headaches.

I will definitely try the other steps, as well. I have a very strong hope that it is simply something that needs to be reset, changed, or re-initialized. I would hope it would not come down to needing a replacement.


We need to fix that ASAP and bring you up to present Hubitat days at work too... :wink: :rofl:


Lol, it's been through the ringer for sure :laughing:

Edit: Meant to also respond to @uncleflip -- whoops.

Yeah no problem -- I'm no @bobbyD but I try my best lol.

Ha, no worries -- Hubitat's done a great job with the firmware updater. The Z-Wave one has been clutch for pushing updates. We just discovered the Zigbee one as well, which we've been testing all our new stuff and that firmware update process is even smoother. Truly amazing.

No worries, keep us posted -- happy to help in any way we can.



Thanks a bunch! I finally got around to giving it a look tonight. I simply did the firmware update, and there's now no sign of strobing or flickering.

My move to Hubitat has been a good learning process. Until this issue, I didn't even know there was a firmware updater app. (Every firmware update I've done has been with physical access to a device, to feed in the data. Even though it makes perfect sense it should be able to be done wirelessly, I hadn't even really considered that. I'd also seen suggestions with other devices, that it wasn't really something I should pursue without Z-Wave plus.) I'm definitely learning as I go. I hope I don't have too many more stupid questions, or situations I should know how to easily fix- but I'm sure there WILL be more. :slight_smile:

1 Like

....and suddenly this morning, the dimmer is back to strobing. Yeesh. Let's try to figure out what the problem is this time....

EDIT: Did the exclude/include/airgap/speak Latin and sacrifice a goat ritual above, and it's back to its non-strobing self. Hoping the normal behaviour continues.