Initializing hub: stuck at 30%

Been at least a week now, hub is stuck at 30%.

I've used the tools at :8081 to revert to an earlier Firmware, tried safe mode, and tried soft reboots. No change.

Help?

Have you tried a soft reset?

1 Like

Negative as I can't find a backup. What all do you lose in a reset?

Were there backups on the hub before it went awol?
If you do a soft reset you will have to load a backup. This can be from the hub itself or from a saved one you may have on a PC.
Did you save one to a PC or something similar?
Is the hub relatively new so that there would not be much to 're-pair' or rules to re-write?

You may wish to wait for support to get in touch if your nervous about doing it.

2 Likes

The hub has been in use for quite some time so lots of programming vested, I know I have a local backup, but not sure where I put it. Do you know the filetype and naming convention? A breif google didn't yield any results.

But since the hub will retain its backups, I will soft reset as I know I had backed up onboard. Thanks for the reminder and confirmation Soft won't toast those. Onward!

Search for files with the extension .lzf

I can confirm @bobbles's suggestion.

1 Like

Well bummer, none of those on my local machine. Hopefully when Backup-Restore finishes running I'll have some backups onboard the hub. Thanks for the advice guys!

:crossed_fingers:

3 Likes

I didn't see the link above, make sure you check this out. If you continue to have any issues, please let us know.

https://docs.hubitat.com/index.php?title=Soft_Reset

3 Likes

Thanks, found that while researching.

Is it normal the Backup-Restore applet to take a long time? Been going now since my last post.

"please do not refresh this page, this screen will close when it is complete".
It auto refreshes every 30 seconds or so. Progress wheel is spinning.

I have done this a few times before but cannot remember how long it took.
I suppose it's like watching a kettle boil. Always seems to take longer.

Just a quick synopsis for anybody else coming back to this post.

I performed a soft reset successfully.
I could not access the Backup-Restore applet. (Hung while initializing)
I performed a firmware update with the hub utility.
I was then able to access the list of backup points. I then downloaded all available automated backups (which only went back 2 weeks or so.)
Then used the backup applet to restore the oldest backup; App hung and was unsuccessful. Rebooted hub.
Used the restore applet to upload my earliest backup file, and was successful.

Problems solved. Thanks for the help!

4 Likes

Download the Hubitat app