Inconsistent Scheduler/Thermostat interaction with CT101

I have a relatively new Hubitat system at my daughter's which is running 2.3.0.124 and working as expected with most devices. However, I am encountering inconsistent performance with the CT101. While the Scheduler seems to be setup correctly with the following typical daily schedule,

the thermostat is apparently given commands that either don't appear at the right time, or at all in some cases. Here is the Thermostat log from last night and this morning:

Note that last evening's 4:30PM heat setting to 70 degrees apparently didn't get to thermostat until 4:34PM. Immediately thereafter, the thermostatSetpoint was set to 65 degrees, although the temp in the house seemed to be rising in response to the 70 degree command. The expected 10:00PM setting to 65 degrees doesn't seem to be there at all at 10:00PM, although it was sent unexpectedly earlier at 4:34PM. It is strange that the temp actually drifted downward through the evening and into this morning when, as scheduled, the temp was reset to 70 degrees at 5:15AM and the temps began to rise. So, bottom line, I guess I'm having trouble understanding the Thermostat logs. Shouldn't they reflect the Scheduler commands with respect to time? Why does the 4:30PM command show up 4 minutes late? And why is there an immediate 65 degree command following?

Note that I'm using the same Scheduler app at my home and another site with expected results (although with different model thermostats in each location). I should also note that the driver I'm using is the CT101 driver. However, the generic driver for the Z-Wave Plus Thermostat was tried with similarly confusing results.

Any thoughts on what I am missing here in interpreting the interaction between the Scheduler and the Thermostat and the resulting logs, and perhaps different heating actions by the furnace?

Couple of questions, do you have the Thermostat set to be "Dumb" thermostat vs "Smart" thermostat?

I don't recall, but does this model have the snap in module for Zwave? If so is it Zwave plus version? In my CT30, I originally and the non plus version and it performed horribly. The plus version cleaned it all up.

This model is indeed a Z-Wave Plus unit, but I am not aware of a "dumb" vs. "smart" setting. The Z-wave capability is built-in, not a separate module as on my home CT50 unit. Note the 0x5E cluster signifying Z-Wave Plus, as I understand it.

Will be at my daughter's this afternoon and plan to take a thorough look at it. May even un-pair and re-pair it to see if that helps.

On the 50's and 30's, in smart mode it runs its own built in schedule overriding what the Hubitat schedule demands. When they're in dumb mode, they just run as a thermostat, no schedules.

I started with the Iris system and the Radio Thermostat CT-101. When I moved to Hubitat after Iris shut down, I also found operation of the CT-101 to be inconsistent. Mine has a label on the back that indicates that it is Z-Wave (not Plus). I would have the scheduler set a temperature. It would change, and then change right back to the previous setting. I ended up getting a Zigbee thermostat, My choice was the Zen Zigbee Edition thermostat. I had some issues with it also at first, but now it is solid and changes at the appropriate times and upon leaving and return.

What may help is to make some rules instead of using the Thermostat Scheduler.

One rule is to control Away/Home/Night settings.
Three rules, one to double check Away, one to double-check Home, and the third to double-check Night settings. These are timed so that if for some reason, the first rule does not set the thermostat correctly, the appropriate rule will then set it.

These are legacy rules and have been operating reliably long-term. Since we are home much of the time, these work for us. You may need to alter them to suit your needs.

This may be the problem for you

I saw this section of the manual and wondered about it. Then, I shut the thermostat off and headed out of town for the weekend. Will turn it back on and see what I learn over the next few cycles. Appreciate the heads-up.

1 Like

Well, I was hoping that some sanity would return to the Thermostat after being turned back to "heat" after a weekend "off". Unfortunately, the strangeness continues. In particular, although the schedule from the Thermostat Scheduler apparently takes some action at the scheduled times, the actual action from the Thermostat itself happens later, at varying delays. Specifically, here is the schedule:

And, here is an example of what is happening:

image

Although the fan is set correctly to "auto" at 10:00PM, the thermostatSetpoint doesn't get set to 60 degrees for some reason until 10:15PM at which time the house begins to cool. A similar situation occurs the next morning when the fan indicates as "auto" at the correct 5:15AM and the thermostatSetpoint gets set to 70 degrees, but for some reason there is another thermostatSetponit setting at 5:27AM, a delay of 12 minutes.

Then, later in the morning, the thermostat fan shows "auto" at the correct time of 9:30AM, but the thermostatSetpoint doesn't get set to 65 degrees until 10:41, an hour plus delay.

image

It is interesting to note that the events presentation from the Thermostat itself shows nothing happening at 9:30 when there was a logged indication of fan at "auto", but there is the confirmation of the thermostatSetpoint set to 65 degrees at 10:41, the hour plus delay.

I'm baffled at this action. Where is the problem, in the Thermostat Scheduler, in the Thermostat driver/logic, or in the CT100 Thermostat itself?

Note, I thought I had a CT101 thermostat (hence the title), but later came to discover that it was actually the very similar CT100, but still a Z-Wave Plus unit. For what it's worth, I am still using the CT101 driver.

What about switching to the Generic z-wave plus driver? (Don't forget to switch to devices first and delete everything then switch to the generic and hit save then configure)

I think that it is time to give the generic driver a try. Thanks for the tip. We'll see....

Well, not much help with the generic thermostat driver.

Perhaps somebody can explain the process to control temperature. I would think the sequence is driven by the Thermostat Scheduler, followed by some response from the Thermostat itself, all of which is reflected in the Logs. Unfortunately, this isn't what I'm seeing. Specifically, here again is the schedule in the Thermostat Scheduler:

And here are the events from the Thermostat device which is supposedly responding:

And here is the log for the time period under review:

So, all seems well at 9:30am when the schedule sets temp to 65 degrees, the Thermostat responds and the temp decreases during the day towards 65 degrees until 4:30pm when the schedule requests the temp be increased to 70 degrees. Although the Logs indicate that there is indeed a change in the thermostatSetpoint at 4:30, it is to 65 degrees, not 70 degrees as expected. Hence, the temperature continues to decrease. There is no corresponding event in the device Events listing until 5:37pm, at which time the thermostatSetpoint increases to 70 degrees (which was expected at 4:30pm) and the temp begins to rise.

So, the question is, what drives what? And, why the inconsistency between the schedule, the device events, and the logs? I know I'm circling around the same issue multiple times, but sure would like to get a grasp of what might be happening, and more importantly, what I could/should do to make it work as one would expect.

Thanks, all, for your patience with my ramblings. All suggestions welcome.

Maybe @bcopeland can throw a word in..

If thermostat mode is auto some thermostats will reject a set change if it is too close to the opposite mode’s setpoint.. Ex heat setpoint too close to cool setpoint.

Thanks for the feedback, gents. Unfortunately, I'm only using "heat" mode with a 25 degree split between commanded heat temps and the thermostat's default cool setpoint. I am going to replicate the heating schedule with some rules and see if that is more reliable than using the scheduler. Maybe that will shed some light on what is happening?

Did you turn off the thermostat's internal schedule and going to the basic mode? It almost seems that once the HE sets the the schedule, something else is changing it back, and the only thing that would do that is the t-stat's schedule.

From all I can tell, the thermostat should be in the non-scheduled state. Unfortunately, the unit is 500 miles away and I won't be able to doublecheck this for a few weeks. This issue has been mentioned several times and I am pretty sure that I have it set so that it isn't acting on its own.

Success! After deleting the Thermostat Scheduler app, I created 4 simple rules triggered by time of day to set the Thermostat to the desired temperature, essentially mirroring what the scheduler was supposed to do. This worked well for the next day, confirming that the Thermostat itself was functional and in the right remote-access state. I then paused my 4 rules and re-installed the Thermostat Scheduler and re-entered the same time and temperature settings from before. Low and behold, system has worked well for the past two days. Best guess, something was messed up within the previous Thermostat Scheduler app, causing the unexplained results.

Thanks to everyone who offered suggestions on this. Not sure what caused the original problems, but very happy that all is well now.

1 Like

Christmas Movies Gremlins GIF by filmeditor

Download the Hubitat app