Included ZW device w/ S2 - can't edit "Device Name"?

On latest HE firmware with my C-7... I just tried excluding / reincluding my Zen 17 after doing a firmware update for it and to bring in back in as S2 (my first S2 device)

Oddly, I cannot edit the Device Name of any of the Z17 child devices (2 relays / 2 sensors) -- they're all stuck at "Zooz Zen17 Universal Relay - Relay 1" (or "... - Sensor 2", etc).

As before, I'm using the native HE Zen17 driver.

Not sure if this is something related to S2, or of it's a Zooz f/w bug or a bug with the latest HE firmware... Any ideas?

I've tried exclude/include several times and several hub reboots -- whatever it is, it's persistent!

ETA - forgot to add that I am able to edit the Device Name of the parent Z17 itself, but that won't trickle down to the child devices.

I think the device name is fixed for "component" child devices, which is a choice the parent device makes but is often done that way for devices that have a fixed number of and purpose for child devices. (Why, I can't say, as from a code perspective I think it would be better to depend on the DNI and not the name if you need to identify something, but I don't know the history of this decision.)

I'm assuming your intent is to affect the display name. In that case, simply adding (or modifying) the device label, which should be the very next field in the UI, will do that. The label is used as the display name, unless it is not set, in which case it will use the name (which, unlike label, is a required field).


Very true this is a 1st-world problem -- being able to edit the Label is most important to me, and that's all good.

It's just odd that I've just never run into this before -- when I first installed the Z17 last year, I excl/incl it numerous times getting it settled in, and I've always been able to edit both the Device Name and Label with the Child devices too.

This is the first time I've included it with S2, so I thought maybe it had something to do wiuth that. But the more likely answe is something in the new HE f/w or the Zooz f/w. And maybe it's not a bug - perhaps that's now how it's supposed to work.

The stuck Device Name really only irks me because theyre each so darn long -- those 4 look very odd in my Devices listing compared to their neighbors.

Thanks for your thoughts, Robert - I appreciate it!