I'm having trouble figuring out how to create a tile to run a rule

I have created a rule that turns off a plug, waits 60 seconds and then turns the plug back on. I have it triggering successfully with a physical button on a hardware remote:

(not sure why I'm not allowed to post images)

I haven't had any luck figuring out how to set up a virtual switch or button that will run the rule from a dashboard. I'm turning to the community for help. Can someone offer guidance?

First, in devices, should I be creating a virtual button or a virtual switch?

When I create a virtual button and trigger it from the commands interface, it works.

Could the problem be that I'm not seeing seeing the devices I ought to be seeing when I try and create the tile:

I'd say a button sounds about right...

Yep. I now have a button working, The issue is that I don't know how to get new devices to appear on the list of available devices for an existing dashboard. When I created a new dashboard, they were there and I got if working just fine.

Anyone know how I can populate the device list for an existing dashboard?

I don't think you can bulk-add devices, just adding them one-by-one using the plus sign in top right corner

All the plus sign does for me is let me add a new tile. When I do that, the list of available devices is incomplete and doesn't have the virtual button I created.

Go to the Hubitat Dashboard app in the Apps section and choose the dashboard you want to add the button to. Then use Choose Devices to add your new virtual button to the list of devices available for that dashboard.

Then go into Dashboards and go to that dashboard and use the + sign. Now you should see your virtual button available to add.

2 Likes

Thank you! That's what I was missing.

1 Like

NP...it's easy to forget that you to do that to add new devices to each dashboard.

I didn't forget. I didn't know! I never did that before. Now I know. Thanks again,

Has the "use all devices" option been disabled by default? You shouldn't need to do that unless it has been enabled (best practice I know, but default??)

Not sure I understand exactly what you're saying. I never used tthe use all devices option myself. I had problems with it behaving properly with my dashboards and so I don't use it.

I prefer to manually add only the relevant devices.

1 Like

@danabw I was not sure if the defaults had changed. This clears it up since he did the action. He stated above that he had never done it before so I was confused as to how the setting was disabled, if he had not done so.

What I had never done before is manually add a device to a dashboard that I'd previously created.

@TechMedX: Sorry - I wasn't clear earlier and was on the way out the door so didn't quite understand what you meant in my rush. :slight_smile: Use all devices is still the default, so it must have been disabled at some point in this case.

Personal rant: I've never liked the way HE implemented the Use all your devices option in the Hubitat Dashboard UI...it is odd that you can select that option and still have the Choose Devices option active. It's not clear at all to a new user why you would have both of those options available at the same time.

If you leave Use all your devices on and then choose a subset of devices thinking that will determine what actually appears in the dashboard, it doesn't work that way. The "Choose Devices" settings don't affect which devices are automatically added if you go into your dashboard the first time and allow it to auto-fill in the tiles - in that case every device you have shows up. Just made me crazy when I first starting using HE dashboards... :dizzy_face:

How about that green check? It refreshes the device list if you add something and you haven't got out of that dashboard.

Yes, but the green check will not do anything to make a device available to a dashboard that was previously created (a dashboard that one HAS "got out of").

You have to go back to apps and choose more devices for the dashboard.