Hue Lighting Question


#1

I am trying to use rule machine to set my Hue lights up. I chose rule machine so I can set a color as I did not see this option in simple lighting. I can get the lights to turn on, but hey do not turn off. I attached a pic of my set up.


#2

Finish filling out the ACTION for FALSE section. That's where you'll turn them off.

Select the same lights and either set the level to zero or turn off the switch associated with the named device. (In other words, the opposite of True.)


#3

csteele, thanks for the reply. That worked like a charm & sorry for the newbie questions. Loving the HE and the learning experience.

Thanks agian


#4

Well, I thought I had it. But the lights turn off, then turn back on automatically. I added another screen shot.


#5

The color command in your false action is causing the light to turn back on. Setting color or color temperature will always cause the lights to turn on to last level.

Also, you might as well just use turn off switch as setting level 0 is the same thing and won't honor your transition time setting. If you want the light to fade to off you will need to dim to something like 5 and then set a delayed off on the switch is longer than the fade time.

I can post an example in a few minutes if that would help


#6

An example would be great. I am trying to understand it, but it is not user friendly yet.

Thanks


#7

In this example motion causes the light to come on at 80% and then turn off after 1 minute of inactivity. It will cancel and keep light on if motion starts again.


#8

Point of curiosity (as I almost exclusively use triggers for time-of-day situations) ... during the [TRUE] period, if someone changes the lights (to blue or whatever), will this rule redetect and set them right back to red again? ie, is this effectively preventing manual changes?


#9

I just test my Hue lights. I made a rule to turn them on to pink and I went into the app and changed the color. The color did not revert to the color set by the rule. However, the color will go back to the set color in the rule the next time the rule activates.

Makes sense?


#10

How do I set the delay to power off the lights after dimming? I tried to add delay but it puts it before the fade to 10.

Thanks


#11

You know, I don't think my suggestion for dim to off is going to be a viable option. I use this technique with bulbs that aren't triggered by motion or won't be re-triggered with motion before the dim to off is complete.

Please describe exactly what you're trying to accomplish with your rule so I can give you a specific example of how to achieve it or tell you why it may not be possible.

Thanks!


#12

Is what I would like to happen is the bulbs dim over a minute then turn off at the scheduled off time. When I choose the dim option, the lights dim then turn back on.

Thanks


#13

Ok let me see if I understand correctly?

If motion is detected you want the lights to come on at a specified level and color
If no motion is detected for x amount of time you want the lights to dim to off (but come back to the original level/color if motion is detected again?

If this is a correct interpretation than this should work, but it may give some "wonky" results, you will have to try it and see.

Explanation:

Motion detected: (rule true)
Light ON at level 80 color Red

No Motion Detected: (rule false)
Wait 1 minute (cancel on motion detected)
Turn off light after 1 minute (cancel on motion detected)
Set light to level 5 with a 60 second fade

Try it and see if it works, please make sure you not the "cancel on truth change" and "pending off" selections.

Only issue I see is that if motion starts again during the fade to off it could have some strange results due to the bulbs reaction to interrupting the fade off command.


#14

No, I do not have any motion sensors. It will be all time based by a scheduled time.

5:30 pm
Lights ON at level 80 color red
11:00 pm
Lights dim to off

This will be scheduled for everyday of the week.


#15

Ok, then you should just be able to change the conditions to "time of day" and you can get rid of the the delay by 1 minute in the false action, and just use delayed off instead of pending off. That should work perfectly.


#16

Thanks for all the help. It looks like i got it to work. I just need to get more accumulated to the terminology & process. Thank you again for the help & have a great weekend.