Hue Bridge Integration App

I have had a Hubitat hub for a few months but just now starting to explore what it can do. I have been working on trying to download the Hue Bridge Integration app but it doesn't do anything. I get a window that says "Hit Done to to install the Hue Bridge Integration. Re-open to setup." so I hit done and nothing happens at all. I have even waited 5-10 minutes but still nothing. I do not get any sort of error in the logs from the user portal. All of my 16 lights are up to date and there is no update required on my Hue Bridge.

To be extra clear, do you mean that it just stays on that screen? What it should do is go back to your list of apps, then you'll see the Hue Bridge Integration app and can re-open it as it says.

Assuming that is the problem, you're seeing, try this: uninstall the app and reinstall it to see if that makes any difference. You might have a "Remove" button on that screen, but if that fails too or isn't there, you can go to the app status (gear icon in the upper right) page and click the "Remove Hue Bridge Integration" button there. I'd then suggest trying again, but I guess a reboot in between (Settings > Reboot Hub) wouldn't hurt. If your database is messed up--and you'd probably see errors in the logs if it was--that would at least restore it to a last known good version.

when I click done nothing happens at all. I have been trying to download the app for a while now. I have exited and checked to see if it ends up in my apps section but it never does. I have went back and tried it multiples times. I have also hit "remove" then tried it again with no success. Also rebooted my hub several times. All of this with no errors in the logs.

Do you have a lot on your hub? I guess even if you do, a soft reset is pretty safe and might help. (A full reset would undoubtedly help unless something is phyiscally wrong with your hub, but that's a lot more work and will require re-pairing of devices, etc.) Have a backup locally in either case.

You might also want to wait to see if anyone else chimes in on this issue. I don't think I've heard of it before. Official Support ( might also have some ideas, but there's no guarantee how fast they (who are terrific, by the way) will respond, so I'd try whatever you can on your own first.

do you have any idea of why my portal wont allow me to delete an app? I have been trying to delete the simple lighting app but it always ends up being in my apps no matter what I do.

What do you mean with "portal"? The is mostly just good for finding your hubs (if they're new or their IP address changed; I'd recommend reserving a static one in your router if possible). After that you can access it directly by IP (or hostname).

If you just mean the regular Hubitat admin UI, then the "Remove" button should work. If something is so messed up in the app that not even that is working, you could try the other option I mentioned above: click the gear (technically "app status") icon next to the app in list view, or in the upper right corner if you have the app open. There should be a "Remove..." button in the bottom right of that view, too.

If none of this works, something is quite wrong. I'd recommend at least a soft reset, but if you don't have a lot and wouldn't mind starting all over, a full reset would be more likely to help.

You sure your HE hub has got internet access ??

I’ve had this happen with the Edge browser. For whatever reason some buttons, usually involved in completing whatever page I’m on, don’t do anything when clicked on. Because of this, I always use the Chrome browser for Hubitat. I have never had this problem with Edge before.

That's good advice too! I've noticed this in Firefox over VPN--I'll click buttons and nothing happens, but Chrome works fine. I'm not sure the VPN really had anything to do with it, but Firefox works fine on every computer except that one, which is away from home (hence the VPN). I thought I was the only one... :slight_smile:

1 Like

Thanks for the advice. I dont know why I didn't think about doing this but as soon as I switched to chrome it worked!

1 Like

Do you have an ad blocker or script blocker or anything on Firefox that might be contributing to this? I do but it's totally disabled for Hubitat on my Windows Firefox, and I don't have any problems with the same configuration on the Mac. I'm just wondering if all of us might have something in common staff could use to troubleshoot the issue if it's not us. :slight_smile:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.