Hubitat won’t trigger from a timer

I am trying to trigger an event from a timer. In this case disarm the HSM at a certain time. But when the time is reached nothing happens.
I tried changing it to turn a light on to see if it was a problem with the HSM, but still nothing.
If I run actions then the light switches on okay.

I’ve also checked that the time zone is correct, which it is.

What am I missing?

Sorry just going to start with the most basic - did you remember to click "Done" after creating or editing the rule? Also it probably wouldn't hurt to click "Update Rule" before "Done". I can't actually see anything wrong with your simple rule!

But do you have the latest hub update? Just in case you have a build that had a bug in rules.


Thanks for that. That indirectly solved the problem.
I did the update rule and done as you suggested and it didn’t make any difference.
So next I went off to find the hub version and noticed on the hub details page that the time was an hour out. I assume it doesn’t take account of BST. Updated the time from the browser, tried again and it then worked.

I had a feeling it was going to be something daft. :roll_eyes: :upside_down_face:

Thanks for replying and setting me on the right track.


And thanks for coming back to let us know what the real problem was - that will be another basic question I can ask someone with a time-trigger problem :smiley:


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.