Hubitat Pings Every Second - WatchDog/DHCP Reconnect

Is this expected behaviour?
I have the Network WatchDog/DHCP Reconnect set for 300s but they are ignored.
Pinging every second is a waste of network so I'd like to find a solution to this.
Am I missing a setting?
Thanks

No. What host/address is Hubitat pinging?

And what apps/drivers do you have loaded on your hub?

2 Likes

My implementation is pretty basic. A few strip lights, bulbs and plugs - all Z-Wave.

The Hubitat is pinging the Gateway.

The only Custom Driver I use is the RGB Genie.

Custom-Drivers

Device List

Maker API possibly? That is likely to be sending data. What is Maker talking to?

There is a switch in the Maker API App to turn off HTTP access. However, no matter what I did, Maker always came up with it enabled.
So, I ended up removing the Maker API App altogether.
Unfortunately, no change - one Ping per Second.

Hmmmm, maybe Settings|Network Settings| DHCP auto reconnect change it to 30 Seconds and save.

2 Likes

Actually, that's how I got here - those settings appear to be ignored.
I change the DHCP setting and it registers when I query http://Hub_IP_Addr/hub/advanced/isNetworkWatchdogEnabled but the pinging isn't affected.
Thanks for trying though!

Is your hub on ethernet or wifi?

Hi theBearMay. I'm using ethernet for the hub w/DHCP.

@gopher.ny any ideas on this one?

Am I the only one with this issue?
Can anyone else check their own network traffic for the Ping rate?
If I'm the one-off then I can research it myself and not take up people's time.
Thanks for all your help so far, by the way. Educational for me!

We're here to help! It'll get figured out one way or the other.

1 Like

I haven't heard of anyone in particular having this issue, but I am not certain that others have looked for it exactly.

At the very least, it is interesting enough that myself and others would like to know the cause. And if it is something the hub is doing that it shouldn't be, then staff would also probably like to know about this.

2 Likes

I certainly appreciate the help!
Let me know what I can tweak/test for you.

I was thinking the next avenue of possible testing is to remove each device and then check the Ping rates.
Is this a good & sound approach?
If so, is the backup/restore on Hubitat robust enough when I eventually need to do the Restore?

Depending on the number of devices and rules I think Iā€™d try disabling the devices instead of removing them.

Yeah, this comes from the hub code. There appears to be a bug where turning the setting to Disabled in Network setup is ignored. It's meant to run all the time only when hub is connected using WiFi, which greatly improves connection stability (yes, at the expense of some wasted network resources). Anecdotally, it appears to help with Ethernet connection stability, too, but Ethernet connection drops are far rarer to begin with, so I don't have the numbers to back it up.

2.3.0 doesn't have the ping running, so rolling back will stop it.

3 Likes

Great to understand this behaviour better!
I'll note that not only is the Disabled setting ignored, but any of those DHCP Reconnect settings is ignored i.e. 1s/5s/30s/300s. None worked.
In my experience the Hub does need some sort of occasional ping since I've had to reboot it in order to get the Web UI back up again.
I'm curious if the Hub "DHCP Reconnect" time equates to renewing the lease? If so, setting lease renewals to seconds is a lot of overhead. Would be nice if the lease time could be specfied i.e. 8/24 hours, etc ...
Regardless of the UI or network, the ZWave traffic is all good over time.
I'll stay tuned for the fix and control over network settings.
In the meantime I'll turn the messages off in my logs. I've put the Hub is on its own FW Interface so it doesn't affect other traffic.
Cheers and thak you everyone for helping in figuring this out!

1 Like