Hubitat Package Manager

I've installed this app, but can't get past the "Matching Apps and Drivers" stage. The first time, I got to downloading package manifiests, but not even that far on subsequent tries.

Does the match process keep going if I check the logs? Maybe I'm killing the process by being impatient and checking the logs?

I've waited up to 10 minutes and never seen the matching process progress. Only thing I see in logs is prefPkgMatchUp.

Tried rebooting the hub, still same.

app:792021-05-25 03:39:52.205 pm debugprefPkgMatchUp

app:792021-05-25 03:39:51.699 pm debugRefreshing repository list

app:792021-05-25 03:37:48.274 pm debugprefPkgMatchUp

app:792021-05-25 03:37:47.659 pm debugRefreshing repository list

app:792021-05-25 03:22:50.294 pm debugprefPkgMatchUp

app:792021-05-25 03:22:49.338 pm debugRefreshing repository list

app:792021-05-25 03:18:54.048 pm debugprefPkgMatchUp

app:792021-05-25 03:18:53.532 pm debugRefreshing repository list

app:792021-05-25 03:14:48.417 pm debugprefPkgMatchUp

app:792021-05-25 03:14:48.005 pm debugRefreshing repository list

app:792021-05-25 03:10:25.148 pm debugprefPkgMatchUp

app:792021-05-25 03:10:24.525 pm debugRefreshing repository list

app:792021-05-25 03:04:46.909 pm debugprefPkgMatchUp

app:792021-05-25 03:04:46.314 pm debugRefreshing repository list

app:792021-05-25 02:54:43.932 pm debugprefPkgMatchUp

app:792021-05-25 02:54:43.513 pm debugRefreshing repository list

Hey welcome to the community. It has at times gotten funky for me. Try uninstalling the app and reboot, then reinstall

Wait, backup, do you have any 3rd party apps or drivers, that you manually installed(ie: copy paste code from github into the hub interface)

1 Like

Yes, I did install some apps by copy/pasting into editor.

Does use of these apps mean I can't use Hubitat Package Manger?

Uninstalled and re-installed package manager (manually, is there any other way?) I quickly got to "Downloading Package Manifests".

How long need I wait before I conclude it isn't working? Or, is there a known issue if I have previously (manually) installed apps or drivers?


But are these apps ones that are in Package Manager? It can only match what developers have submitted to the repository.

A matchup usually takes a few minutes the first time, the HPM screen should indicate that matches were, or were not found. Don't exit out of that matchup screen manually, let the app indicate when it is ready for you to click Next/Done or whatever.

I've just tried the 'Match Up' on one of my hubs to test and it has stopped at the same point.
Update notifications are working OK as I got an notification of available updates today and was able to update.

@dman2306 has something gone amiss? Just wondering.

@davethomaspilot from memory things don't normally take more than a couple of minutes. Been a while since I have tried it though.

1 Like

Ok, I'll keep waiting without exiting. Which means I can't check the logs to see if an error has occurred?

But are these apps ones that are in Package Manager? It can only match what developers have submitted to the repository?

I don't think I understand the question. I don't know if the ones I installed manually are in package manager or not.

I'm not installing package manager for those, rather to install new ones. Specifically, the one that provides a text to speech interface to Amazon Echo devices.

It still says "Downloading Package Manifests". Been about 20 minutes now.

Right click logs tab, open in new tab/window. You can then switch freely between the two screens.

If you don't have anything to match, then why do the match option? You should instead be using the "Install" button, then look for Echo Speaks.

But if you DO have manually loaded apps (previously added to hub) that are in Package Manager, it will then take over keeping them up to date.

1 Like

You can check logs, by hovering over logs, right click open in new tab

1 Like

When I tested it just now to see if I was getting the same, the logs are just a duplicate of what appears in HPM when doing a match. I'm afraid they don't give any clue as to what is happening.
If you don't mind, can you try a match up? I'd be interested to see what you get.

1 Like

If you don't mind, can you try a match up?

Not sure what you mean. All I can do is exit and try the same thing again. Which I've done seven or eight times already.

Subsequent attempts didn't make it to "Downloading Package Manifests". After removing and re-installing package manager, it quickly got back to the manifest download after "refreshing" many packages;

Hubitat Package Manager
Matching Installed Apps and Drivers
Matching packages... Please wait...
Refreshed dman2306
Refreshed BPTWorld
Refreshed bcopeland
Refreshed storageaanarchy (SANdood)
Refreshed RMoRobert (BertABCD1234)
Refreshed Matthew (@scottma61)
Refreshed heidrickla (Lewis.Heidrick)
Refreshed Miles Budnek (@mbudnek)
Refreshed AaronW
Refreshed Dave Gutheinz(DavGut)
Refreshed Markus (@markus)
Refreshed Joseph Kregloh
Refreshed Inovelli
Refreshed Anthony S. (tonesto7)
Refreshed MFornander
Refreshed nh.schottfam
Refreshed mircolino
Refreshed imnotbob
Refreshed apwelsh
Refreshed bsileo
Refreshed napalmcsr
Refreshed Marco Felicio (
Refreshed Brian Wilson (@brianwilson)
Refreshed thomas.c.howard
Refreshed Arn Burkhoff
Refreshed n3!
Refreshed lnjustin
Refreshed christi999
Refreshed ardichoke
Refreshed jrfarrar
Refreshed mikec85
Refreshed dennypage
Refreshed Justin Walker (augoisms)
Refreshed Russ Vrolyk
Refreshed Reid Baldwin
Refreshed Rory Jaffe
Refreshed Jo Rhett
Refreshed craigde
Refreshed Kurt Sanders (kurtsanders)
Refreshed Chris Sader (chris.sader)
Refreshed Joel Wetzel
Refreshed mbarone
Refreshed SRWhite
Refreshed jedbro
Refreshed CSteele
Refreshed dkilgore90
Refreshed Eliot Stocker
Refreshed Botched1
Refreshed bchubitat
Refreshed tomw
Refreshed LGKApps lgkahn-hubitat
Refreshed cjcharles0
Refreshed Ernie Miller (@ernie)
Refreshed ajones
Refreshed Dale Coghlan (@dcoghlan)
Refreshed TonyFleisher
Refreshed tagyoureit
Refreshed Taylor Brown (@thecloudtaylor)
Refreshed ZRanger1
Refreshed Rangner FG (@rfg81)
Refreshed Nelson Clark
Refreshed John Callahan (@johndc7)
Refreshed viertaxa
Refreshed BirdsLikeWires (@birdslikewires)
Refreshed Jeff Page (@jtp10181)
Refreshed Doug Renze (@darthbob)
Refreshed JVM (@jvm33)
Refreshed Amos Yuen
Refreshed Matt Hammond
Refreshed akhandok
Refreshed Neil Jackson
Refreshed Jonathan Michaelson
Refreshed Rob Heyes
Refreshed droath
Refreshed benevolent
Refreshed MHedish
Refreshed Awth Wathje
Refreshed ymerj
Refreshed Michael van Dam
Refreshed Vincent van Didden (@Vincentiano)
Refreshed Snell
Downloading package manifests

Location: hubitat
Terms of Service
Copyright 2021 Hubitat, Inc.

That was directed to @Rxich. That's why I included his quote.
Perhaps I should have been a bit clearer.

1 Like

Hmm, seems to be broken here too. Stalls on Package Manifest step. @dman2306

It has been a while since I installed this, can't you get to the main menu without doing a match upon initial install? Once it is installed, like mine, you have choices of what you want to do. Does that not happen with a fresh install?

1 Like

No, there's no option. It never gets installed since it hangs during the initial match process.

1 Like

@davethomaspilot it looks like there may be an issue.
Myself and @neonturbo are seeing a problem as well.
It may be worth waiting for @dman2306 to comment as he is the package author.



I just tried mine and it's got an issue with package match up (on my C5) The release text for version 1.81 of the app says it fixes a freeze for a failed matchup, yet it appears to still be occurring.

Appears to be a bug

Good pickup @davethomaspilot

1 Like

I can reproduce it, not yet sure what's wrong though.