Hubitat Package Manager (HPM)

Over the last three days, I have gotten an update for HPM through HPM. Afterwards, I noticed a couple times that HPM is indicating that there are available updates. When I check for updates, there are none and then the indicator that says there are updates is cleared as though I applied them. This has happened three times now since the HPM update. Any ideas?

run repair. if you continue to see the issue, post in the HPM thread :slight_smile:

3 Likes

There was a window in which the HPM I released fixed a problem that didn't actually exist... it was a phenomena only for the person developing HPM (ME.) That "fix" caused what you're seeing, I believe a Repair, which always pulls down the absolute latest version with the flaw removed, should fix it for the future.

3 Likes

The repair sort of hung forever. Interestingly, when I aborted the repair after several minutes and I went into HPM update, it showed HPM could be updated. I executed that and it seemed to work. Apparently there was corruption because although the HPM screen indicated it was v1.8.5, the update I saw after the hung repair indicated it was v1.8.3 and was upgrading to v.1.8.5. Now it seems to report all packages up to date. Interesting. My next step was to manually remove and install, but I didn't need to it seems. Thanks so much for the great advice!

Going that far seems unnecessary to me :smiley:

Apps and drivers aren't required to contain a version and those that do, implement it in a variety of ways. Adding a visible version to HPM was one of my ToDos. It makes it easy to know you're using the intended version. View however displays the version from the Manifest, and is what HPM uses for its comparisons.

Well... I call that a "fixed a problem that didn't actually exist" :smiley: Less angry pitchforks that way :smiley:

This is exactly what's happening to me. For the last 3 days, every morning HPM indicates it has updates. I can clear it by selecting "Update", which reports nothing needs updating. But then the next morning it is back again.

Did you try the Repair path?

Click Repair and choose Hubitat Package Manager.

Exactly Joe. Apparently that is the corrupted HPM.

I have about 7 packages installed. Yesterday I went an repaired each one. Unfortunately didn't make any difference.

Just one package needed Repairing. Doing more is of course fine, but it's only HPM that has an unneeded line of code. :smiley:

I experienced the same exact thing. Repair hung and I cancelled. Went back in and it showed there was an update for HPM. Ran that and it brought HPM to v1.8.5. Everything looks good after that.

I've seen the same thing happen.

Two of my hubs eventually got to "No updates available" after updating twice, repairing, and updating again. A third took about five tries, but eventually got there with the same process.

1 Like

So, a day later and no phantom updates and also no new updates. I feel like it is fixed. Waiting for one of my 50 or so apps to get an update as the acid test. I am certainly pushing the limits.

1 Like

Not sure if this has something to do with my installing Bundles but HPM Package Manager is throwing an error on Device Watchdog.

This looks to be an HPM error generated by a missing or incorrectly formatted package manifest. Manifests are created/maintained by the package developer (i.e. not the HPM developer). In this case it is one of @bptworld's manifests. I am aware that he is pulling some/all of his apps out of HPM eventually in favor of his Bundle Manager app; this may be one of the first to make that transition. If that is the case you'll have to remove the app from your HPM instance to remove the error - I believe @csteele has or will soon add an Unmatch capability to handle this situation.

4 Likes

Hi,
Not sure when or how often HPM checks/updates the manifests but once HPM does this, the error will go away. As I move each app over, I delete it from my manifest. So if HPM is using an older manifest, you'll get that error.

@csteele, I looked real quick and didn't see a way to force a manifest update within HPM. Maybe this could be another addition? Would solve this issue, not just for me but anytime a dev may leave HE for any reason.

1 Like

Me either but it's minutes. I've been editing a particular Manifest, then testing, edit again.. and it's true, it takes a few minutes to go active. I haven't measured it, just know that a trip to the kitchen usually is enough time :smiley:

You're talking about this kind of a feature?
Screen Shot 2022-06-10 at 7.16.45 AM

Screen Shot 2022-06-10 at 7.17.34 AM

Screen Shot 2022-06-10 at 7.17.47 AM

Will be the central feature of v1.8.6

1 Like

Nice! I was thinking more of a '1-click' method though. 'Click to refresh/update manifests' with a button. HPM is an amazing piece of work but that's the one thing that always drives me nuts... click, then click.. hey click again. lol (that's the main reason I don't use RM) Maybe just me. :man_shrugging:

1 Like

Download the Hubitat app