Hubitat modes not available in IFTTT

I'm trying to set up my Blink cameras to arm when the mode in Hubitat changes. This seems easy to do, but there are no modes available in the modes drop-down in the IFTTT applet.

Has anyone experienced this? Any ideas?


I can do exactly what you’re trying to. Not sure why you can’t see hubitat modes in IFTTT.

In the IFTTT Hubitat app there is a drop down menu to select which modes you make available to IFTTT, just select which ones you want to grant access to.


Indeed there is, it just doesn't list any modes to choose from. It only says 'Options Unavailable'.

Hmmm...that's an applet you made yourself? I was trying to use the canned version.

You need to first select the modes in the integration App in Hubitat before you try and make an applet.


Any modes you select should then be visible in IFTTT under a mode action.


Ok, great. I'll try that.

Thanks for your response!

@Christopher is probably right. If you didn’t install the IFTTT app in your hub’s apps page, that’s likely your problem. Wouldn’t matter whether you use the canned IFTTT applet or you put one together yourself.

1 Like

That was it! Thank you both for taking the time to respond to you.


1 Like

I that same regard in using IFTTT turning Blink off and on depending which Mode Hubitat is in, That works fine BUT I also wanted to add a trigger in Hubitat that if the HSM was set to away then the Mode would change to AWAY and therefore Blink camera would turn on and if HSM was set to disarm then Mode would change to Day and therefore Blink camera would turn off. Everything works PERFECTLY however in my Hubitat logs every time these triggers engage I get a "DEBUG" notice. If I click on the debug it sends me to the Hubitat section that shows what I have allowed IFTTT to work within Hubitat which is everything! I've refreshed what is allowed and still the same Debug notice. Should I worry about the Debug since everything works fine? The only thing I can figure out is since HSM is not listed for what IFTTT can work with maybe that is triggering the debug. Any help would be greatly appreciated. New to Hubitat

Name the Trigger*
If Alarm set to arm then Mode set to armed

Select Trigger Events
HSM status becomes Armed Away

Select Actions
Mode: Away

So it seems every day or two my blinks fail to arm or disarm. Then I go in to IFTTT and show the hubitat mode as "LOADING" and if I click it, it shows it cant access the service.
BUt yet it works (and the logins are great) for a day or so... very strange... any ideas?

IFTTT just redid their ENTIRE website and I think they screwed things up. I to am getting the same thing as you posted "LOADING" . I even tried rejoining Hubitat and still the same thing. I'd give them a day or so to fix what they broke.

Just checked IFTTT Help area, Apparently their service connection is down and their investigating. So hold tight its not us or Hubitat.


Just checked TODAY 7/30/19 and IFTTT seems to have everything back in order. HOPEFULLY it lasts. I guess little road bumps with the new software, but you should be able to choose your mode now for Blink

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.