Hubitat Light Green but Won't Register Device


#1

Hi,

I tried to set up the Hubitat but it stopped midway. The light is green but won't go to next step to complete setup. Does anybody know what to do?


#2

email Support@hubitat.com to open a Ticket.
tag @bobbyD

Support is going to be more aware of the quirks than the Community, I think. The new C-5 revision of the hub hasn't been out as long as it takes to have the Community be aware of the standard fixups.

Did you get past the Registration and into the download/install of the latest OS?


#3

Yes, it downloaded the latest version and then it said wait for it to complete. Once it completed, it went to the next page but then it didn't load. It said it cannot load page.


#4

Did you set up a DHCP reservation? You want a static IP on this and any extras (Google Home, Lutron, Alexa, etc.) so if you don't know how to do this, we can help. If you're more interested in figuring it out, you'll want to manage the ISP router (WiFi) and set it up in there. The MAC address is on the bottom of the Hub.

Send an email to Support@Hubitat.com and expect to see a robo reply.

You may want to try a reboot.


#5

I was looking for the reboot thread but couldn't find it. I'm not sure how to do a DHCP reservation. I just started with dabbling with smart home and such. I have my own router, not using ISP router.


#6

Equally good. Open the management interface and find the DHCP reservations area. You haven't mentioned the router brand/model but here's a quick sample I found for an Asus RT-AC66U:

https://event.asus.com/2012/nw/dummy_ui/en/advanced_dhcp_content.html

There, close to the bottom is a button to enable Manual Assignment and after doing that you can fill in the next two fields..the Mac address from the label on the bottom of the Hub and whatever IP address you want it to use, forever.

Clicky the save this and that and then reboot Hubitat. (Pulling the power plug and plugging it back in will work, although it does have a chance of corrupting the internal DB. Since you have nothing, a corruption isn't very likely.)


#7

Ok thanks! It worked.


#8

I have the same issue except it never found the device and has been searching for about 30 minutes. The wired thing is the light is green and according to the documentation should only show green after the hub is registered.

Did you ever hear from support don't think I will hear from them tonight. Not a good first impression at all.


#9

Can you find the IP address of your hub? If so, you should be able to use it without it showing up on Portal.

You can register your hub via the message in the upper right or visiting /hub/register once you have completed the initial setup.

There are several reasons why a hub might not show up in portal, you can try the advanced section to search by mDNS, MAC address (on bottom of hub) or via a network scan.

Typically, the reasons are the hub and the computer / device are not on the same physical network or separated by a bridge or router, for example, a wifi connected device might not be on the same LAN or IP address range that the hub is physically connected via ethernet.

If you check your firewall for the list of connected devices (via DHCP) you should be able to find the hub, and connect to it directly. Also using the Advanced, MAC Address search will return what IP address that device is reporting to Hubitat.


#10

Thanks for the info that is the weird thing the portal is just stuck searching has been doing this for an hour now. I try to click on anything for advanced search it does nothing. I will see if I can locate the IP address I may need to rebuild my ubiquity controller though to access the dhcp leases I migrated my DHCP server to the networking equipment awhile back when my server crashed.


#11

Forgot to mention I'm using Chrome should I use another browser.


#12

Chrome is our main tested browser.

Let's start by letting me know your network config, if you would like feel free to PM me the details.

If your wired lan and wireless are on different networks, it will never find it in portal.

You can also download a network scanning tool like Fing and see if it finds the hub via IP address.

As for advanced not working for you, double check you don't have any intrusive browser extensions and try restarting chrome in safe mode or try another browser.


#13

I don't use any vlans or anything currently been planning on segregating my network with vlans but my son streams on twitch 5 days a week and has for the last year. So I don't manage my network or make changes like I use to simply to avoid impacting his stream . I use an USG Pro as my router two USG pro AP's and 24 port POE switch and another 24 port non POE switch.

All devices are able to communicate across my network they are all on 10.1.10/24 subnet for wired and wireless devices.

I was able to access my controller but not finding anything new with MAC address assigned to my hub.