Hubitat, IFTTT, Google Home/Assistant How To?

I am feeling really dense right now . . .
Until such time as we have integration, I would like to be able to issue verbal commands to a Google Home to turn on or off devices on my Hubitat hub. I have loaded the IFTTT app on the hub and authorized access to all the lighting devices. I have enabled the service from IFTTT to both Hubitat and Google Assistant. Now I'm stuck, I don't understand how to create what is needed so I can issue a voice command to Google and have IFTTT pass it along to Hubitat to execute the command.
Leads to explanatory links appreciated. My searches have, so far, been fruitless.

You will need to use Google Assistant Relay. It runs off of a debian server and you can pass commands through it!

Here are step by step instructions to setup Google Home or Google Assistant to Hubitat via IFTTT

  1. From IFTTT Home Page, click on "My Applets" at the top

  2. On the right, click on "New Applet"

  3. Choose if "This" happens...

  4. The "This" in your case will be a voice command to Google Home or Google Assistant. Type "goo" in the search box and you will see the choice for Google Assistant.

  5. Click on Google Assistant and then choose what your trigger will be. For this example, we'll just choose a simple phrase.

  6. Click on "Say a simple phrase" and then fill in one simple phrase. You can also add two other phrases, but if you keep it to just one, it'll be easier to setup multiple phrases for the same trigger from the Google Assistant app. Here you can also enter how you want your assistant to respond when you say the phrase. To keep it simple, I'd recommend just entering "OK".

  7. Click on "Create trigger", and then choose the "then that" action that should occur based on your trigger.

  8. Type "hu" in the search window and select the Hubitat action

  9. In this example, we're going to turn on a device

  10. We will select the dining room light attached to Hubitat for our action. Your devices you have selected in the Hubitat IFTTT app will show up in the drop-down menu. Just click the arrow to select from the list.

  11. Click "Create action" and confirm your applet is built the way you want.

Note: For troubleshooting, you may sometimes want to leave "Receive notifications when this Applet runs" enabled, but most of the time you will want to disable this.

  1. Open the Google Assistant app on your phone or tablet, then go to "Settings" and then tap "Routines". Here, you will create multiple phrases to trigger your one IFTTT phrase you entered in your Applet.

  1. Create a new routine by tapping the blue circle with the + symbol, then choose what will happen when these phrases are spoken. Here you will enter the trigger phrase from your IFTTT applet.

  1. Easiest way to enter the phrases, is to use voice dictation on your phone or tablet.

  1. Repeat these steps for turning the device OFF and other actions you may want, such as dim, movie time, dinner time, etc.

Huge thank you. Your instructions are perfect. I got it working immediately! Thank you very much!
I feel so silly, I didn't realize the "if this" and "then that" were clickable links! I should have wandered my mouse around the page and watched for links. Old guys sometimes learn slow. Thanks again!


How would you use Assistant Relay to control devices connected through Hubitat?

One you have Google Assistant Relay setup, you use Rule Machine and the TTS capabilities, choosing Google Assistant as the speech device. Adding [CC] at the front of the "Custom message to send" value, such as [CC] Turn on the dining room lamp. That command for google assistant could be linked to a lamp that is attached to an unsupported device by Hubitat, but one that is supported by Google Assistant. So instead of speaking “Turn on the dining room lamp”, Google Assistant will not speak the phrase, but will instead do that command.

If you want a verbal reply to your silent command, you instead prefix the command with [CCC].

The whole point is that the device is not in Google Assistant because there is no Hubitat - Assistant Integration. LOL. If the device was in Google Assistant, you wouldn't need any of these commands. You would just use "Google, turn on the ...." Since the device you are trying to control isn't in Assistant, you can pass all the custom commands you want and it still won't work.

Sorry, I misread your question. Correct, There is no Google Assistant app for Hubitat at this time and you cannot use Google Assistant Relay to control a device attached to Hubitat, but you can use Hubitat to control a device that is connected through Google Assistant, without speaking.

Just went to IFTTT to connect my Hubitat account but I keep getting 'Could not connect service'. Anyone knows what I could be doing wrong?

What version of firmware are you using? Do you have the IFTTT app installed on you hub?

Last time this happened to me a quick reboot of the hub cleared it up.

I updated to the latest firmware this morning so it is the latest one. I have the app installed on the hub. I will try rebooting it later today when I get home.

I have rebooted the hub but still not having any luck. Is there something wrong with my Hubitat account?

Could be, support would have to check that. If you email them at I'm sure they can figure it out.

I will contact support, hopefully they will sort it out quickly.
I would also like to know if the integration with IFTTT is only one way or both ways. I would like to control my Yeelight bulbs which are in IFTTT through Hubitat. Is it possible?

Yes. Here's THIS

and here's THAT

1 Like

Did you ever get this resolved? I'm new to Hubitat and having the same Could Not Connect Service error.

I believe Hubitat is currently having issue with its Cloud platform again today. Place a ticket with HE support so they are aware of the issue.

1 Like

Sent an email to support but didn't get any response. I have found their email support to be not very good unfortunately. Hopefully they will work on improving it. Otherwise, I love Hubitat overall.
Last time I checked, I was still having the issue. Will give it another go this week.

FYI just tried again tonight doing the same steps and it went through as expected.