Hubitat + Google Home + Switching Modes


#1

Things are working smoothly with Google Home and Hubitat for me lately. (After that software update that fixed that "random bulbs are offline" issue)

I'm still having the problem where asking Google to change the mode works, but google always reports an error. I searched around for people but I found threads from a few months ago.

Any tricks for me to fix this issue? I don't switch modes often but I need to sometimes and it's a little annoying. :slight_smile:
Thanks!


#2

I get the same error.

I ended up creating a virtual switch that changed the mode and then using that in a Google Home routine.


#3

Ditto what @ansible said.


#4

Is there any possibility that Hubitat would fix this?
It should work by default, this is the error from the logs:
executeCmd- java.lang.NullPointerException: Cannot get property 'online' on null object


#5

Best bet would be to file a ticket with support.


#6

Thanks ansible. Your solution worked for me.
I set up virtual switches in Hubitat for each desired Mode. Then used Mode Manager to set mode with these switches. Then, Added switches to Google Home and also used in GH routines.


#7

I usually don't use GH for mode changes but recently have been and noticed this problem is still present. Was a ticket ever created for support? Or maybe someone from HE staff can comment on if its on the list of items to be fixed.