Hubitat™ Dashboard V1 Documentation

ok. it should be ... but seems the fix didnt make it in yet.

Anyone with issue with an old Ipad 2 on ISO 9.3.5 with columns? I could not have more than 4 columns on the display. No issue with all my other devices except with this iPad. Actiontiles and smarttiles are both doing fine. I tried with multiple browsers as well with same result.


Is their anyway to show the Safety Monitor status in a tile? I have searched but cant find away

Thanks NEIL

Currently, no. This is something that is scheduled for 1.1.1 release.

I read through most of the discussion about the button template, but it focused mainly on the momentary capability.

I'm not sure what this template is this designed to do.
For instance, I added one of my button controllers, selected the button template and the button number. When I click the tile, my expectation was that it would send the event that corresponds to that button push and any apps subscribed would execute as coded. However, nothing happens and I get the following exception in the logs.
Command 'push' is not supported by device. (dashboardCmd)

What am I missing here?

What driver are you trying to use? What capability for button does it use? What is the driver expecting? push(number) or on(number)?

From the sounds of it, the button controller driver doesn't use our pushableButton capability or similar Hubitat's button implementation

The momentary tile, will send the on command to a driver for use in places where a switch capability is used, but there really isn't an off state, just need to send on.

I tried using multiple button devices, including the built in Remotec ZRC90 and Pico. They all utilize the pushableButton capability and follow Hubitat's' button implementation.

I just reread my initial post and may have been unclear. The template I was asking about was the button template and NOT the momentary.

We are discussing this internally. For now, it is recommended to use virtual buttons as proxies for these devices and then use those virtual buttons in dashboard.

LOL...My plan was to use virtual button devices on the dashboard but I wanted to ensure I understood the intended use of the button template first.That's why I tested with my existing physical button devices before building the virtual devices and got the errors reported. I'll create a virtual button device and test soon. Thanks for responding.

Ok..so I created a virtual 6 button device. Added it to the dashboard using the button template and get the following when its tapped:

errorjava.lang.NumberFormatException: For input string: "null" (push)

Alrighty...just updated to the 1.1.0.122 and now the virtual button reports pushed events as expected.

??? - as long as it's working now I guess.

Glad its working, nothing should have changed so far as with dashboard and the push command...

Feature Request:
Now that we have the new upgraded Hampton Driver, can we also have a fan template?
My suggestion...after selecting fan template, present new field to choose fan speed (numeric). Tile should act as a momentary button and when pushed, it sets the speed accordingly (using setSpeed command).
This way it can be tied to both the fan controller parent device and the fan component device.

The dimmer template could be used for light control on the parent device and the fan light component device.
The dimmer template could be used for "gradual" fan speed control on the fan component.

In addition, it would be nice to have a "Fan Controller" template eventually, where you could control the light (on/off/dim) and the fan speed.

I think this was discussed at one point.

But can we get the ability to change a device's label on an individual dashboard?

Also making it optional to hide a tile's label would be great too.

Thanks!

It's on the feature request list. As is fan control.

Thanks for the feedback!

3 Likes

Just update to Firmware 1.1.0.122. I now have issues with dashboard tiles. the dimmer slider has moved lower on the tile and when viewing on tablet it cover the bottom text. The attached image is from google chrome on windows. Any ideas @patrick?

I have similar issues on my phone when the device has a long name that needs to wrap to a second line.

A couple of other small issues I came across today setting up my fan speed button. In the pic below...I added image tiles with the button numbers and overlaid a button tile. The button tile was configured for highest level of transparency. If you look at the image you can still see the outline of the button icon and also the button tile text at the bottom. Any way to get complete transparency?

The other thing I noticed is that the custom template colors are not taking properly. In the above pic it shows the yellow color I set for attribute tiles. When I set a new fan speed the tile shows with the default white as seen below. If I refresh the webpage, the correct yellow color appears.

1 Like

Download the Hubitat app