Hubitat C5 - updated firmware and now getting Wifi setup captive portal

Have you tried from other devices / browsers? I think in the other thread the user said some devices it worked fine and others he got the Wifi portal page.

It must be effecting a very low percent of people, since it has only come up twice on here. We are probably talking less than 0.1% of users

I have not, but if troubleshooting help is needed, I'm happy to participate. I work in the world of consumer router/WAP firmware and know how difficult it can be to repro some issues, only our users aren't typically technical or willing to help troubleshoot which leaves us in a tough spot, especially with the devs/QA folk being several layers removed from our customers. Most of our customers could never have done what we just did here. It's kind of awesome having a product where you know almost your entire customer base is going to be technical .... and it's probably also a curse because we will find everything wrong :D.

1 Like

Oh you should visit the Get Help section, there are plenty of non-technical people in there!

Also, speaking of Router firmware, I have been using Asus with the Merlin firmware for a long time. That's where all the techy Asus users hang out. Most people in there seem to be somewhat handy as well, or otherwise they would not be flashing custom router firmware.

1 Like

I hear you, I used to run stuff like DD-WRT and Tomato on a WRT54G back in the dark ages. Ok now that this is behind me, I'm going to go see if there's an update to the Lutron Bridge Pro stuff.

LMAO, I have zero clue how the heck these pico remotes have been working at all. I had the Lutron Bridge Pro IP address in Hubitat still pointing to 192.168.x.x when I moved to 172.16.x.x maybe 2 years ago? How is that even possible????? This is a redundant question, just laughing at my own idiocy.

This seems like an appropriate place for a follow up. I just purchased a C8 Pro. The migration instructions include updating my C5 to the current version (in order to perform a free cloud backup). As we've established I cannot update the firmware from 2.3.4 without the wireless captive portal issue, I'm stuck as to how to perform the cloud backup.

Can I just perform a local backup from C5 2.3.4 and load it to the C8P?

And if someone from Hubitat would like me to send in the C5 for troubleshooting of the firmware update issue, LMK.

Local backup wont get you zigbee and zwave radio data.

I think the biggest issue is the C8P needs to be updated so it can see the migration backup.

I think if you were able to use 2.3.5 you would then have the migration backup options on the C5, that is when the C8 came out and the migration backup was added to the platform.

If thats not working then I think @bobbyD might have a workaround he can setup for you?

One other thing to note, I have seen a few people post that C5 to C8P was not migrating z-wave. I am not sure if it happens to everyone or just isolated cases.

With the luck I'm having, I'll be one of those cases :D. Ok, I guess I'm stuck until @bobbyD can provide a workaround. 2.3.5 as per above is a no go. TY

I enrolled your hub into beta, see if you try updating to 2.3.8, if that helps.

ty, will give it a go.

@bobbyD unfortunately, same thing with 2.3.8 as it was with, 2.3.5, 2.3.6 and 2.3.7. is the most recent firmware that doesn't give me this captive wifi portal.

See my private message.

Huge thanks to @gopher.ny for figuring out this corner case. We are now up and running with 2.3.8 on my C5. i also found a bug on the C8P that broke my network. Both are only an issue if your network is 172.16.. and both will be fixed in future firmware.