Hubitat app on Android no longer sending enter/exit geofence

Issue started w latest update, ~ 2/13. Prior versions were very reliable. Checked settings: location/battery settings and all look correct.
Also in debug logs, I see regular NETWORK_CHANGED, don't remember seeing that before
TIA

I’m noticing same issue on mine. And same thing in debug log.

I noticed the same thing - it started about 10 days ago or so. I tried to troubleshoot here.

That particular error has since been resolved - I suspect something was wrong with the HE cloud servers. I received no update from HE staff.

But, I did notice that in my HE android app, it had somehow changed the permissions for location to "only when using the app". I know it was previously "all times". I didnt change it myself, and changed it back to "all times". I've not yet left the house to determine if it's working again.

Great catch, mine changed also, I'll post if that fixes it. Thanks!

Mike where is the setting ? Don't see anywhere in app.
TIA

On your phone, settings, applications. Hubitat, permissions, location.

Mine changed after the last update. Fixed it but still not very reliable.

High accuracy method is enabled, it hasn't changed. Where are the " only when using the app" & "all times" ?
Thanks

I'm running Nougat and there is no settings in the app to set these parameters.
Thanks

I'm on Android Q and my setting has not changed. It's also continued to work fine.

Question for those who's found it has changed, do you have battery optimization enabled for the app? It's possible the OS changed the setting in an attempt to preserve battery when it noticed the app was accessing location when not in use.

No, I dont have battery optimation for the HE app.

My problem was, after hubitat update, battery setting was changed to optimized. Changed back to optimization off; appears to working again.
Thanks

Changing the "per app" didn't fix ours, will turn all optimizations off and report. Thanks!

Turned off ALL optimizations on phone, no change. Aggravating that it no longer works. But I'll keep trying. Have to be sure to turn HSM when leaving and clear when arriving manually.

Anybody with issues using a Huawei device?
The "power genie" power management system that Huawei uses on their devices overrides whatever optimization settings you have set in android and force apps/services to go dormant in the background. To get any geofencing to work properly (not just HE, but ST, Life360, etc..) I had to hook the phone to a laptop and forcefully remove power genie.

Even after fixing the battery optimization, I'm seeing a ~ 15 min lag w status updates :shushing_face:

I've checked all settings, battery optimization off; location high accuracy (phone/wifi/bt) and the latest version of HA is not more accurate(reason for the update). If anything it's worse.
Example today: exited 09:44 entered 11:53, received 2 notices; left again within 5 minutes, came back 2 hrs later; no posting for the last two events......

Any luck... using a Huawei phone and it just doesn't work. Not even getting Send Geo events to work... worked once when I enabled wi-fi...

any ideas?

Download the Hubitat app