Hubitat Android Widget

I have to log out of app, relog in. Then I can load a widget and my entire device list shows up to pick from. And it works when I pick something. I can turn whatever I pick on/off. I haven't really used this other than testing as the 2x2 is way too big.

I tried locking out locking back in deleting the cache everything and still cannot get that widget to work. It worked once where the item showed up but nothing worked. That was on the older version of the mobile application and firmware. However, I can't seem to get it to work again. I keep blocking out and lock back in and I'm hoping magically it'll start working.

I just figured it out. It's not so much about logging in and logging out you have to leave the mobile application running in the background when you add the widgets. If you don't do that it can't talk to the mobile application to get the list of devices. However, still none of the devices work for me that I've selected. I haven't tested them all but most. They do work from the device tab and everywhere else, but not from the widget. Yes, I agree the one by two or whatever it is is big and bulky. I will say it's a step in the right direction.

So in summary make sure you have your mobile app open when you add the widget otherwise you will not see anything listed.

2 Likes

Have you tried removing the app and re-installing it?

@bobbyD thanks for your reply I think our message is crossed. You have to keep the mobile application open in the background when you add the widgets. I think this is the step that most people are missing. Thanks for getting back to me.

1 Like

I've 1) started the app and have it in the background while trying to add a widget, 2) installed and re-installed the app.

I can't get past the configure screen.

1 Like

You'll need to allow the app service to run in the background for the widgets to work, not only when you add them.

Do you have any devices available on Devices tab?

You mean like this? :slight_smile:

No. But on the Tools -> Devices screen, they are all there. But I imagine that's just a browser window into my hub, not actually in the app.

Correct, any device that is placed in a room, and shows on Devices tab can be used in widgets.

Doing what Bobby says, leave app running in background works for me. And I can control the device just fine.

1 Like

Thanks! Odd thing is it did start working and I don't have the application running but adding you do.

Now is all seems to be working.

Thanks.

1 Like

Not working for me, can add the widget but clicking it does nothing.

Uninstalled and reinstalled, turned off battery optimisation, devices work in the app but not the widget

Do they work on Devices tab in the app? Next up is make, model and Android version of your mobile device.

Work fine on device page of the app
Samsung s10
Android 11


Interesting Same issue here, tried all above solutions, I just see two devices on the configure page, and they are in different rooms. Both are SmartThings Outlets. But there are many more of those.

They do control the devices though! It's a start!

Would be nice for HSM!

I notice that in the widgets list it says 2x1. But when you put it on the screen, it’s 2x2. Still too big for me either way.

2 Likes

Any update? Tried a phone reboot, removed and readd a widget

1 Like

any dice on this? I got it installed, devices in rooms, widgets made, battery optimization off, app open, widgets let me choose a device, do not actually control the things. C4 hub 2.7.125

Works for me on a Pixel 5.
But it seems that only one widget at a time works. And it is hit or miss, for which device works.

Sonoff zigbee works the best for some odd reason.

Download the Hubitat app