Hubigraph Tile not showing

Hi there, I'm having trouble getting hubigraph tiles to show. I can see the tile device as an optional tile, but I don't know which tile template to select. None of the ones I've tried worked.

Here's what I've done:

  • installed hubigraphs via HPM
  • Set up the local storage
  • Created a Gauge
  • Configured that gauge for the data I wanted
  • Enabled the Hubitat Tile Device
  • Added the tile device to my dashboard via the dashboard app.

Here's where I'm stuck, I believe the next step is to place the tile on my dashboard from within the dashboard. I CAN see the tile device.

Which template do I choose? I've tried several, but none seem to work. And/Or did I miss a step?

Thanks in advance.

1 Like

The template should be Attribute and then over to the right you need to select an attribute. Graph or Graph_No_Title

That did the trick!

Side question: Before posting my question, I looked everywhere for documentation on how to use hubigraphs. Is there documentation somewhere that I missed?

No documentation, I don't believe. You should read through the Hubigraph thread. It's a community developed app by @thomas.c.howard so for him it'as a hobby and writing documentation is a whole new can of worms, which he probably doesn't want to deal with. I think the first post is probably about all your going to get on that front. Read his FAQ in the first post.

He has been absent in the thread lately so I am guessing he is taking a break or has much more pressing issues to deal with.

Are you saying that in the Attribute drop down there should be the options of Graph or No Graph? If not, where is the Graph/no Graph option?

Looks like you got this working. If I go to Apps/ Hubitat Package Manager / View Apps and Drivers, it lists a bunch of Hubigraph related items under Hubigraph, so I think I have Hubigraph installed. However it does not appear to show up anywhere else.

  1. How /where do you "set up the local storage"?
  2. How/ where do you create and configure a Gauge (or do you mean dashboard tile?)
  3. How/where do you "enable the Hubitat Tile Device?"


Did you install the app? HPM just loads the apps and drivers, you still need to install it from add user app on the apps page.

1 Like

Yes, I just figured that out. Thank you. Appreciate it.
I'm also trying to follow chowell's directions. Where he listed "Set up Local Storage" is it possible he mean to write "Set up Long Term Storage"? When I click on the apps I see that option, but not local...

Not sure what he means by local storage. Probably does mean long term storge.

You can setup your graph and then decide if you need long term storage. You don't have to have long term storge enabled to create a graph.

Terminal3 - thank you very much for your help.
I got Hubigraphs installed, then in Apps I "created" graphs, then associated my devices with the graphs, then installed the Hubigraphs tiles in the dashboard app (in apps section) then went to dashboard and got the Hubigraphs working.
This was really great - exactly what I needed.

Then tonight I went to the Hubitat and it asked to be updated. OK. Installed the update.

Then went to Dashboard and my Hubigraphs Tile no longer show data - they are just a gray box, with a note stating "[IP address] took too long to respond"

I just checked and the IP address of my Hubitat is one number off of the IP address shown in Hubigraphs. Maybe somehow installing the update changed the IP address?

How do I fix this? I don't know anything about IP addresses other than that they exist...

When I go to Apps, and click on one of the Hubigraph "child" apps specific to my install, there is a section labeled "Local Graph URL. The address at the beginning of that url matches the current IP address of my hub. The next section is labeled "Preview" but the preview of my graph also does not show.

Still inside the Hubigraph child app there is a section labeled "Disable OAuth Authorization" If I click "disable API" then reenable it, I can suddenly see the preview of the graph in the child app, but it still just shows the same gray box in the dashboard.

I tried restarting the Hubitat. Same problem.
I tried creating a new dashboard and inserting the tile with the re-enabled API. Same problem.

Any ideas?

It is best to have a static IP for your Hub, but not necessarily required. You can go to settings > network setup and set your IP as static. The best method IMHO is to set your IP static on your router. That method is usually not difficult but it is router specific and you would need to access the router setup to do that.

All that said, you have to keep in mind you can't view graphs on your dashboard if not on your local network. This is a limitation of HG that the developer said he might look into but never did before he abandoned the project. There may be an alternative to HG coming soon, so maybe you might want to hold off spending too much time on it.

So when using the mobile app if you look up on the upper right corner of the app and you see a little cloud you won't be able to view your graphs on the dashboard. That is because it is connected via the cloud and not your local network. If you are on your local network and you touch that cloud it turns to a little house icon. You should then be able to see graphs on your device. You should always be able to see your graphs via the web interface.

Thank you for the reply.
I don't have the mobile app and only view Hubigraph locally. This issue happened locally.

Before I read your response, I accidentally figured out how to fix the graphs not showing issue - I moved the slider at "Enable Debug Logging" to turn it on. Somehow, just moving that slider fixed it. I've googled to attempt to understand why, but have no clue. As far as I can tell, enabling the debug log is only supposed to supply a log to facilitate troubleshooting.

Regarding your recommendation that I set my router to give the Hubitat a static IP. I will look into doing that. However, before I do so, is there any downside to doing this?

Regarding holding off spending too much time on the graphs - appreciate the heads up. I have plotted the initial graphs. The data visualization helped me identify numerous issues, so I'll focus on addressing those. I'll wait for this alternative to HG to be available before spending time on the pretty pictures! LOL.

The alternative I mentioned was released today. Basically all of the hubigraphs features are now in webcore.