HubConnect Thermostat not controllable in ST

In an effort to switch from ST to HE I move the Honeywell zwave thermostat to HE today. I removed the old instance from ST, and then using HubConnect I added the Thermostat back to ST. It shows up and gets all the readings in the device driver and in the "recent" ST screen, but I get a blank window , and an error when I click the gear. pic attached. Anyone know how to resolve this?

Unable to duplicate.

I have a Thermostat on my Server/Coordinator Hubitat Hub and I just now selected it to be sent to my ST hub.

I installed the HubConnect Thermostat driver taken from github repo, under the SmartThings/deviceTypes folder into ST IDE, then clicked Done (all the way out) on HE.

The device showed up briskly and all the UI info is there, including clicking the Gear.

I'm using Classic App, if that makes a difference

How does HubConnect handle a missing driver(DTH) when creating devices? Will it just skip over or try with a default driver? Because this would only happen if the incorrect DTH was assigned at device creation by the smartapp. If no driver existed, no child device should have been created by the smartapp. If it uses a default, after installing the DTH, @TechMedX, you will have to go into the IDE and assign the correct DTH to the device.

The device seems to create fine and gets the correct DH from what I see.

If I check the events and the temp is going up as correctly and being displayed correctly on the main ST Things tab.

One thing to note, I just remove the Thermostat and added it back to HE and then to ST (same result). I did see that when it came into HE it comes in as "Device" I have to go into the HE device and change it to "Generic Z-Wave Thermostat" then it works fine in HE. I add it to HubConnect and ST AFTER I make the device change in HE.

Mine's similar, but I'm not seeing the HubConnect version number... are you using this one in your ST IDE?

In the IDE, edit the DH and scroll to the last line... should be this:

def getDriverVersion() {[platform: "SmartThings", major: 1, minor: 3, build: 1]}

I just installed everything today and yesterday, so it should be current.

I just "imported" my plug to ST and it also has no version, but it works fine. Not sure if that helps or not.

No mine says

def getDriverVersion() {[platform: "Universal", major: 1, minor: 2, build: 1]}

@csteele That worked (slow repsonse time, but working)

Only one minor issue, I cannot control the "Fan" from Auto to ON on Circulate. Not a big deal just a observation. Thanks a ton for the quick responses and helpful insight!

One last thing to mention - I followed the link the in app to get the correct driver. I just double checked and the link take you to the "Universal" DH not the ST DH. Maybe the link can be separated into two?

Just a thought, Cheers :beers:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.