Hub stopped working

Hi,
Today my C7 hub stopped responding. I cannot access the GUI interface anymore. I am not sure what IP address it was set to. I tired find.hubitat.com like always but no connection. I tried rebooting the device several times but still no connection. My Hub has been unreliable since the day I bought it. Every few often it just dies on me but in the past a reboot will fix the issue but this time it is all dead. I see the green light on front of the unit and also the ethernet light on the switch side is green but it does not blink. I tried using MAC address to access it but no luck.
Kanwar

Can you get to the Diagnostics Menu (http://<yourHubIP>:8081)?

What color is the led on the hub?

Press and hold the network reset button on the bottom of the hub for 7 seconds using a paper clip or toothpick. This will be the only round hole out of all the square ones. Then wait a few mins. Open a browser and go to http://hubitat.local and see if anything comes up. If nothing does and the light is green, google angry ip scanner and download it. You should find it that way (note the mac on the bottom of the hub)

Thanks for the response.

  1. Did the reset from the C7 reset button on the bottom. The light starts alternating between green/blue/orange color briefly and now settled on green.
  2. Found the IP address of C7 from Orbi Router Gui to which C7 is connected.
  3. Using the IP tried to open the C7 page and got this message.
  4. Did the soft reset and now the hub is working but I have lost everything. Is that what was suppose to happen? There are no devices or rules. Shall I just go ahead and restore from the backup or re add all the devices first and then restore?

Hub should have been making backups automatically, go to Settings|Backup and Restore|Local Backups and click on the restore icon
image
for the backup you want to try to restore.

2 Likes

Thx. Do I get devices back in the process? I am at work and will try when I get back home.

@Kepcoate Yes your devices will be there when you restore the database because you havent erased the radios. That said you should get a hub protect sub. That will back up the radios whereas the local backups dont.

1 Like

Thx. Everything seems to be working. I updated the software as well. It is not clear to me why does C7 hangs up from time to time (once or twice a month). I use C7 to monitor my home alarm system and I got broken into last week with C7 stuck in unresponsive state while we were away. Is there a way to find out why C7 becomes unresponsive? When I say unresponsive I mean it stops sending notifications on the phone. It might have been working locally but I did not check it. In future I will do more troubleshooting.

I have another hub being used at a different location and it also do the same thing and rebooting it fixes the issue. That one is slightly better and need a reboot once every two months or so to get the notifications going. That hub I think works fine locally during that time as it triggers exterior lights controlled by it and I have never noticed them going dead on me except one time.

Look at pushover. It has always been rock solid for me

This could also be only an issue with the mobile app and the hub may be working fine still. Have you switched to the new Mobile app 2.0 yet?

Although usually if it is on the app side, rebooting does not fix it so I am leaning towards the hub is locked up or struggling.

One easy solution if you feel like it happens every month or so, might be to setup a reboot schedule to reboot the hub once a week (using RM or a custom driver/app). I am not usually a fan of scheduled reboots but once a week is not bad, do not recommend any shorter than that. If the lock up is from resources that might fix it. Often times though the lock up is from something else where a reboot schedule does not solve it.

Now that I have been looking at the rules I have setup, none of the rules work when the C7 stops sending notifications. So that means the C7 itself is freezing and not just the notifications. Not seeing this message on the forum , so copying questions you asked from my email.

Do you have jumbo frames enabled anywhere on your network?
No, not that I am aware of. I see 1500 bytes of frame size on the router.

Can you post your z-wave details page in it's entirety? (Use windows snip)




What lan integrations are you running?
Note sure what is the meaning of Lan Integrations.

Are you monitoring memory loss?
No

What platform are you on?
IOS ( if that is what you are asking)

Updated the app to 2.0. One weird thing is that the app is using the old IP ( Dynamic IP, as seen in the app "My Hub" page) as now I have setup a static IP for it. I can open the C7 page using the static IP but app does not update it. How can I force it to pick up the new IP?