Hub restarting problem - initializing stuck at 10%


I found my hub in unresponsive state. It was not even being pinged from network.
So I powered it off and then back on.

Now it responds to ping. But when I access the web interface it shows "initializing 10%"
I have been waiting for more than 15 minutes now.

I believe that's not normal ?

What can I do ?

I can also access on port 8081 but I did not want to reboot or shutdown without asking first.

shut it down with shutdown command and started back.
now it is 70%

oh that was weird.

Did you get it up and running?

yes it is up and running now.
but I see "high cpu load" on the UI

I did not make any changes to the configuration, no new devices or apps for the last 2 weeks.
why the high cpu now all of a sudden ?

Ok, now that you have it running, take and download a backup to your computer (settings, backup).

Then, log on to the Diagnostic Tool page (hubIP:8081) and do a Soft Reset. Details here:

When the hub reboots to the Getting Started page (green), there is a small link at the bottom of the page. Go there, rather than setting up the hub, and restore the backup you just downloaded. That will clean up any mess in the database.

Then, look at the app and device stats, see if there is anything consuming a large amount of resources. That should put you on the track to figuring out what is happening.

Do you have any power metering devices? Sometimes they can be very chatty if the monitoring is set for lots of reporting.

1 Like

thanks. actually I did not soft reset as it was working after the incident yesterday.
Does the backup-restore procedure clean anything really ?

Because I had thought that if I just restore what I backup it will be the same.
Does it clean anything when restored from backup ?

In fact, I am not at home for the last 2 weeks and did not add anything to the config (or change anything)
since it was working fine before I left 2 weeks ago, I expect that it should work the same.

I have a power metering device but I don't use the metering feature. again, it is not a new device. it was there 2 weeks ago , still there.

Yes. The Backup process exports records from the database and cleans things up.

Now, a corrupted database might not be your problem. Your details were minimal, so I was just trying to eliminate a corrupt database as the problems.

But I would still suggest that you look at the other items I suggested for investigation as well.

Also, make sure your hub is on an uninterruptible power supply (UPS). Power fail is one of the most common causes of database corruption.

1 Like

actually now I tried to look at runtime stats , it did not respond. (runtime stats button on the menu)
then I tried another page (devices) it showed the devices page but a "Severe hub CPU load detected." warning is shown now.

so , how can I identify what is causing the high cpu ?

If you've done the soft reset and restore then go to apps and disable them all. and then start turning back on one by one till you can get to app stats

Only way is to get in right after a reboot and start disabling devices. From your description, it really does sound like it’s a power metering device. Or, a device has gone nuts and is spamming your mesh. Sometimes the spamming can be fixed by a reboot (power cycle) of the device. The “nuclear option” to do that is to shut your hub down cleanly, then cycle the breaker to your home. That will power cycle all devices that aren’t battery powered.

But, the best first approach would be to focus on the power metering device. If reporting thresholds are set wrong, they can overwhelm a hub with reports. I assume that your logs aren’t showing anything unusual, right?

Another option would be to have Hubitat support look at it - they can access internal logs that users can’t. Open a problem ticket with .

logs do not report anything wrong.
btw, I may have other power metering devices that I am not aware of.
how can I find all the devices with that feature ?

how do you disable devices ?

That’s covered in the hub documentation:

Off the top of my head, one quick way would be to create a rule in rule machine, make the trigger a power report, and see which devices are in the drop-down menu that comes up.

thanks but in the documentation it only shows disabling apps. there's no disable button in the devices list.
what am I missing ?

Apps and devices have the same disable feature.

You have to click/tap the X at the top of each page, which will then reveal the X next to each device or app in the list on their respective pages.

Greyed out X = active
Red X = disabled

I shutdown muy hub. Wait 15 minutes and start it with a cool cpu.
Most of the cpu comsuming apps are disabled now.

Even with a fresh start I am not able to access "runtime stats"
whenever I try that , I get the "high cpu" warning and page timeouts.


I see these but in reality, only the Bedroom Outlet 1 and Bedroom Outlet 2 is able to report power.
They are Samsung Smartthings power outlets.

So should I disable them ?
what about the other "false" ones ?

I dont know, but it never really hurts to disable a device or app while troubleshooting an issue that could be related.

If disabling doesn’t lead to resolution of the issue, then re-enable.