Hub mesh wrong IP

I'm using Hub Mesh and my second hub thinks my first hub is on a bogus IP address. It used to be correct but somehow got changed and now nothing works. It shows IP as which is the universal bogus IP address. The correct subnet is 192.168.4.x

How do I change it?

I rebooted both hubs and now neither hub is showing on either hub mesh screen

Really annoying... I rebooted a few times and neither hub is showing the other. Both are on the latest firmware update. One hub is C5 the other is C7. Used to work, but now both are ignoring each other. Any advise?

I’ve been using HubMesh on 3 hubs for a while now and never saw this.

Tagging @gopher.ny.

Yea it’s really weird. Hubs just don’t show up. Both working fine and home network is healthy. I use eero mesh routers if that matters.

Also on Eero mesh router. Very odd that it’s not working anymore for you…

Are there any errors in the logs from either hubs?

I hard rebooted both hubs by shutting them down and unplugging them and restarted them both and now it is working fine. Super weird. Nothing was in the logs.


Exact same issue. Exact same solution.
Unifi network. So I don't think that eero had anything to do with it.

Happened again today after a power outage. Used the same solution and yes it worked again. Would sure be better if you could just type in the IP of the hub. Hey @gopher.ny Can that be added to the dev roadmap?

I'm bumping/resurfacing this old issue because it is still happening. It basically happens every time my hub shuts down due to a power glitch or outage, which in my area unfortunately happens a lot. The workaround is known and reliable, but super annoying. It requires both hubs to be shut down gracefully and cold rebooted at roughly the same time and then they reconnect with the proper IP's. So my question to the care-takers of the hubmesh app (which by the way is truly amazing when the IPs are correct) is whether a modest tweak can be made to the app to allow the user to manually specify the hub IP's? Anyone who is geeky enough to use hub mesh is geeky enough to know their hub IP address so why not enable this? Not sure who to tag on the HE team so I'm tagging @bravenel who will know what to do.

So you have a static IP set (or DHCP reservation) it sounds like? So how is the hub mesh getting a wrong IP is its not changing?

There is an endpoint you can use to set an IP (not sure what it is, someone probably has it handy).

Also, new feature on 2.3.6 in Settings > Hub Details, set the "Hub name on LAN" to something unique for each hub. It helps speed up the mDNS discovery.

There's an endpoint to set initial hub mesh peers. Now that the issue surfaced again, I'll probably add the to the UI as well.,, with comma separated IP address list as a query string. It should say "done" when list is updated. The list takes effect when hub mesh is restarted next time. resets the list. shows the list in plain text.


I did this on both hubs. Power flickered today and I got the bogus IP again, so the problem still exists

What bogus IP? It is a 169.254 address? Usually that means the hub is having an issue getting an IP from DHCP, and maybe it sorts itself out shortly after but gets stuck in the Hub Mesh info?

I'd put it on a UPS so I didn't have these issues.

1 Like

Yea - it gives back the 169.x address. A reboot of both hubs always fixes it. UPS is a good idea for both hubs because one is in my data closet so everything will benefit, and the other is close to my ring alarm so it will benefit too. I also have solar so the UPS only needs to work for a few seconds before I get power back (unless it is night and then it take 20 seconds for my F150 lightning to kick in). Either way i can buy small ones.

If your router is also going offline with the power outage, the hub is rebooting faster than the router and then getting the 169, address. It sounds like once the router comes up the hub is able to connect and get an IP but the hub mesh does not get updated with the new IP. Does that sound right? Just trying to break it down for support as a possible bug that could be fixed. @gopher.ny

1 Like

That sounds exactly right. My router reboot process is extremely slow for some reason. I think the Eero's that I use have to do a bunch of hand-shaking and then wait for the slow comcast modem to deliver a WAN before things are good. Meanwhile Hubitat is rebooted and doesn't know the IP so gives the bogus 169 address. The fix of putting my main eero and comcast modem on a UPS might work but the other 3 eero's will still barf and do the handshake thing. We'll see. Any other ideas?

Seems like a bug with Hub Mesh. I know they improved the reconnect logic in 2.3.6 so the hub should hopefully be reconnecting once the DHCP comes up. At that point the IP in Hub Mesh should be getting updated but apparently it is not.

It sounds like you have power flickers pretty often though, so a UPS on the main equipment would definitely be a good idea.

As a general rule, if my mesh is down, I won't be able to connect to one or more hubs. A reboot of my router gets everything back to normal.