Hub lockups?

Looks like you're replacing your last webCoRE Piston with a few RM Triggers (based on the other active thread.) That's a good call as I always experienced slow downs of my hub when running webCoRE in the very early days of Hubitat.

I see you're using the community developed Echo Speaks App. While I am not pointing any fingers, I believe it is fair to say that Echo Speaks is a pretty large, complicated App. I ran it on my development hub for little while just to test it out. It is an impressive application with a ton of features. That level of complexity is what concerned me a little. I decided to wait and watch the experiences of others who chose to use it. It might be a decent place to start with temporarily disabling it to see if that helps.

Just some ideas to consider. I have been trying to limit my use of custom apps that perform a lot of LAN/CLOUD based transactions to see if I can see any impact on my own hub's performance. It is a bit frustrating at times, but I know eventually the community and Hubitat developers will get to the bottom of what is going on. It is just going to take some patience.

Lately, with all of the recent firmware updates and hot fixes, my hubs have been rebooted regularly. I haven't had anything lock up recently. Not sure if this is due to improvements in the hub firmware, tweaks I have made to my configuration, or the fact that rebooting ~once a week is helping. I have 3 Hubitat hubs now, 1 production and 2 development currently. I am trying to move most of my custom code to 1 of the development hubs to see if I can make the problem move.


Hub has stalled at 85% when trying to open -- in the registration area. I have been dealing with this now for 2 days. 60 devices going crazy or all of this stuff out of order... really frustrating to get anywhere and restarting the hub just makes it worse it seems. I'd love to just be able to factory reset the Hub I have -I have backups but may just start over - the instructions I found need me to use a usb-- my hub does not have usb. I sent support a message but have not heard back yet. If anyone has a trick to get in, so I can disable things, then great -- but just getting past the log in screen is impossible now. There have been a number of restarts where the light goes from Blue to Green -- but in that case, it just sits there on a blank screen waiting for my ip address to the Hub to respond.

Excellent points and ones I have also noticed and share.

This essentially my line of thinking as well. I have been getting lockups every couple of weeks since the beginning of the year. I have been good for the past month but as @ogiewon mentioned, my hub has also been rebooted more regularly because of updates. The last thing I removed was influxDB (a known culprit) and so far so good, but I also moved as many of my Lan based apps to my dev hub.

1 Like

I certainly believe Chuck when he says they want the errors to be visible to us... However, let's pretend there are 'hidden' error logs we don't get to see... The hub is written/runs on Java.. and for a completely different project on a completely different product, I had reason to look to Google to help me with a java Error.. I bumped into "50 Common Java Errors and How to Avoid Them" article...

#1 is:
private static double volume(String solidom, double alturam, double areaBasem, double raiom) { double vol; if (solidom.equalsIgnoreCase("esfera"){ vol=(4.0/3)Math.piMath.pow(raiom,3); } else { if (solidom.equalsIgnoreCase("cilindro") { vol=Math.pi*Math.pow(raiom,2)*alturam; } else { vol=(1.0/3)Math.piMath.pow(raiom,2)*alturam; } } return vol; }

My point is.. maybe 'hidden' would be a good thing? :slight_smile: ( missing/extra ; or } problem)

More to Chuck's unspoken point is that if there ARE Java errors then he/they would not say "there's a user code problem."

1 Like

Here you go... the soft reset procedure is very simple and does not require re-pairing your devices. The hard reset is the full nuclear option.

1 Like

@tebiv1 is there a reset pinhole on the hub? Not sure, just asking as there usually is something like this.

I would agree with @ogiewon and his ideas. However, my hub was locking up prior to implementing Echo speaks. In an effort to try to get some decent speech synthesis in my smarthome, I decided to try to implement my echos as my sonos speakers don't seem to be able to speak and then resume what was playing before speaking. I don't know if this is a wide spread problem across HE, ST, etc. with sonos but I would love to get this working again. Then I wouldn't want to use the echo dots for speech.

1 Like

None of us add these features to our hub in order to get them to crash. I think that's a given :smiley: We all want the feature because it enhances our home automation. I do, I know that.

I added Homebridge, and at least one other app that is on the 'bad app' list. (never tried WebCoRE on Hubitat though) And I'm not giving up my Homebridge... or at least what it brings.. Presence sensing for me. I HAD to find another solution... my solution is not anything close to what I wanted at the time... I dedicated a Hub to Homebridge, ApiXU driver, and everything else I thought was contributing to occasional slowdowns (and as you know, slowdowns are often a precursor to crashes.)

"Get a dedicated Hub and run WebCoRE on it" is NOT what I'm saying (to you or anyone) but we are all seeming to do so much more with this Hubitat hub than what I was doing with 4 hubs a year ago, before Hubitat. The resources of the hub are fixed and the imaginative things we are sharing here to do with this collection of devices and hub(s) (like Lutron, Hue, etc.) are just bursting. I use ApiXU and it's calculated LUX vs my 12 Aeon MultiSensor 6 Lux readings to detect "gloomy day" and then bring some lights on. I never did that with my past Hubs. Spoken alerts?? I never did that with previous hubs.

ApiXU is gathering data every day, all day and it asks for about 60 individual data points. That's the standard response from ApiXU as far as I can tell. So it's a requirement that we 'eat' 60 items to get the 5-25 items we care about. (15 for me, specifically.)

Be aware, during your Disable Apps adventure that you MAY be running into an "it takes two" problem. It may be that it's a combination.

Do you have multiple HE hubs? Do you link them together? And if so, wouldn't one slowing down or crashing cause the others to also slow down and possible crash?

Multiple?? Yes.. I have multiple hubs... 3 Hubitat Hubs today.

I forced myself to power up a SmartThings hub in order to be more helpful during the testing of HubConnect. Which means, at this moment, I have 4 hubs.

It was my choice to conclude that more hubs was a good 'investment' to protect the investment made in the 150+ devices scattered throughout my home. It's not for everyone...


I did try this but it just sits at the log in screen— and says “waiting for 192.168.x.x and never responds. I’m trying to just get past this screen at this point. Just before this happened, I got a red flag, with the message saying that I needed to register… So I clicked on the registration page re-entered my info and it said I didn’t need to use it I was already registered.. Then it progressively got worse the more I was working on my network putting in my door locks so I had to move the hub in order to get it close to the door locks and one hub location would drop the other lock so I kept going back-and-forth all day long this idea of having to move the hub around is bologna and I even have switches at my doors near the locks to work is repeaters for the Z wave And the more I restarted the hub after moving it to go from one location to the next the worse it got -- I now know better and have a 200 ft extension cord along with my ethernet cable.

It looks like most of your devices are running through the Main hub?

I have no "real" devices on my 'coordinator' Hub. A virtual device using the ApiXU driver is the closest thing.

However, all of my devices are 'mirroring' their state/status/attributes to 'coordinator' because that's where Dashboard lives. If I want to see it on a Dashboard, I have to mirror it over (well... I 'have to' in my architecture. My choice, my demand that I run just the one Dashboard.)

RM is running on all of the (Hubitat) Hubs. Everything I can run on the "Floor Hubs" I do. 100% of the motion/contact/time of day/illumination lighting is running locally on each "Floor hub." In other words, 'upstairs hub' takes care of all the physical devices that exist upstairs. All sensors and switches and outlets and...everything on that floor is being managed by that hub and no other.

'coordinator' allows for collecting or presenting common products to the "Floor Hubs"

The LUX example above is what I'm referring to.. I get the Lux info via ApiXU and I get Lux info from the 12 MultiSensors and device on 'gloomy day' and turn that virtual switch on or off. It's the virtual switch ONLY that is distributed to the "Floor Hubs" to use.

1 Like

I know I owe you a few beers, but this diagram is exactly what I want to do in my home.

Still without any answer from support of why my hub has no cloud connection...

Where you have RM installed?

Yea, no cloud is going to make a ST integration via HubConnect a solid challenge! But who needs ST anyway?? LOL

I have RM installed everywhere.. well... every Hubitat'where. Each 'active radio' hub manages 100% of the devices connected to it. 'coordinator' manages things like Lux (from ApiXU and myMultisensors) and Presence and distributes 'answers' to the others. It also acts as an intermediary for 'side to side' traffic, but that's a very minor use, so far.


I am just trying to figure out how to keep my one hub stable. Can't imagine trying to implement more hubs into the mix.:wink: Although, I would like to try homebridge just for the presence sensors but apparently I need a more current ipad.:roll_eyes:

OR an Apple TV OR a Homepod speaker.

Get an AppleTV 4th gen for cheap somehow and just plug in in the wall and network. Don't even bother hooking it up to a TV... treat it exactly like a Lutron or Hue bridge. :smiley:

Never thought of that! It has to be the 4th Gen Apple TV?

Bought one! :smirk: Now I will have to learn how to connect it all up.