Hub locking up

Hello all, About once a week my hub locks up at night to the point I have to power cycle it. I can not find anything in the logs that is causing this to happen. I am also on the latest firmware. Any help tracking this down would be great.

I have already contacted customer support and they said they are no longer able to login to hubs for privacy reasons. I don’t like the thought of no support.

Can you post some screenshots of your logs and your settings, zwave details pages? Also what version of hub firmware are you running?

Say what?

1 Like

Support of one's particular configuration and attached devices has always been via community support only. Hubitat support will help with hub hardware issues, but they do not support device issues and conflicts caused by devices and custom code.

I have found in the years I have been a Hubitat Elevation owner, that a hub "lockup" has always been cause by either an attached device misbehaving, or a custom driver I have installed, particularly custom drivers that communicate via IP. That's not to say that simply having a custom driver or app causes issues, but that would be the first place to look if you are having issues and running custom code.

You'll need to provide the community with more information about your particular devices on the hub.

For example, I once experienced severe and frequent unresponsiveness from my main hub when I had two 300 series Z-Wave home energy monitors together with my newer 500 series S2 devices. I was also refreshing them very quickly for my particular use. Once I moved them to a separate hub by themselves, the main hub and my secondary hub have both been stable. This is just one example. Over time I have found certain custom code could run fine by itself, but when combined with certain other custom code, it would cause an issue.

This document explains how to disable custom drivers. The process is the same to disable custom apps. This allows you to test if the issue is resolved by disabling, without the need to uninstall. Be sure to reboot after disabling custom code to ensure that it isn't still running.


I don’t think they could ever do that?