Hub goes offline daily

My Hubitat Elevation C-7 had been working fine up until a couple of weeks ago, when it started to become unresponsive roughly once a day. The green light stays on but it seems uncontactable over the network. However, timed actions continue unaffected. The only resolution seems to be to restart the hub. I'm not sure how to go about debugging this. The hub is fully up to date, and I had made no configuration changes around the time this started happening.

Some information people may need to understand what is going on.

  • Hubitat Firmware version
  • Once a day?
    • Is it at the same time each day?
    • If so, about what time?
  • Router Connect: wifi or Ethernet cable?
  • Router: Have you reserved the IP Address for the C-7?
  • Did you make any significant changes to your LAN a couple of weeks ago?
    • New device(s) with high data rates
    • WiFi 6 devices
    • Modified Router/Modem parameters
    • Change of Router/Modem
1 Like

Everything @djgutheinz mentions will be very useful in diagnosing the issue. In addition here's one quick thing you can check as well...

Go to Settings and choose Network Setup. Try changing Ethernet speed to fixed 100mb and DHCP auto-reconnect to every 30 seconds. If Ethernet speed is already set to fixed 100mb you might change it to auto-negotiate.

Thanks @djgutheinz and @brad5 for the replies.

  • Hubitat version:
  • Frequency is hard to pin down because I don't notice until I try and turn a switch on or off. As I said, timers continue to fire! But I rebooted it this morning and within hours it had become unresponsive. I think this is pretty typical. It's not the same time of day, ie, not on any kind of 24 cycle.
  • Hub is connected by ethernet.
  • No reserved IP
  • No network changes that I can recall. Certainly didn't change the configuration and I don't believe I added any devices to the network at this point.

Per @brad5's suggestion I have toggled the speed to auto negotiated from fixed 100mb and set DHCP reconnect to 30 seconds.

When the issue occurs next, try connecting via http://hubitat.local to see if it works.

This is something I suggest changing. When you reserve an IP address in your router's DHCP server it ensures the hub gets issued the same IP address every time. Without a reservation, it is possible under certain conditions for the router to issue a different IP address to the hub. A reservation just checks off one more item in troubleshooting. It's also a good idea for any devices with which your HE communicates via IP (Lutron hub, for instance).


It does not.

This is for me the important angle in setting a fixed IP. If you're comfortable going into your router's settings, I prefer to set all fixed IPs on the router, so that all the fixed IPs settings are contained on the same device. Much cleaner and easier to manage, and you won't accidentally create conflicting IP settings.


I'm not a fan of DHCP reservations. For me I think of it as a workaround for devices that don't have the ability to have a static IP address assigned (Sonos players being one such device). I can understand the convenience of using the routers DHCP reservation table as a single point of administration; however occasionally when the DHCP mechanism goes pear shaped you end up with an uncontactable device with an auto assigned IP address in the range. I keep DHCP for mobile devices only (without reservation), DHCP with reservation is used only for devices that cannot have network parameters manually assigned, that would benefit from a static address. For all other devices I assign a static IP and either use a spreadsheet to keep track or run IP Scanner Pro app on my MacBook prior to assigning a new address to any device.

Has never happened to me on routers I've owned (From Dlink to Netgear to Unifi/Edgerouter) but if you have experienced that frequently enough for it to be an issue, then your approach of course is fine as long the info on assigned IPs is up to date. :slight_smile: Unfortunately for me, I've learned over the years that I am not the guy who will reliably remember to keep that kind of manually updated info current for my devices. :wink: Also, don't expect me to remember what I've gone to the grocery store to get. :smiley:


Tentatively this may have fixed it (either the fixed IP or the Ethernet speed?). Will update if not. Thanks all for the suggestions.

1 Like

How many unclean shutdowns have you done now with this hub? This could have exacerbated things by corrupting your database. Have you also applied the new z-wave stack after you updated your platform last time? As said above, either set a static ip on the hub itself or do a DHCP reservation. This will ensure a consistent connection (as recommended above, this should be done with any devices that HE interacts with)

You may not have made changes to the hub, but have you made any changes to your network? Even updating the router's firmware can result in similar issues you describe.

Keep us posted. If this fixed the problem, then the router settings may have changed (or the network switch that the hub is plugged into).


@user757 It is also possible that your router automatically updates its firmware. If it does, and there's a way to turn it off, that might not be a bad idea. The upside is you are never caught unawares by an update that might degrade performance. One downside is in the event of a security patch to fix a vulnerability (like the log4j fiasco last December) you will need to update the router manually.

Would be curious to know what kind of router/switch/network configuration you have, especially if the problem re-emerges.

1 Like

My hub acts like that every time there is a software update pending.
All automations work as expected, I only notice when my google home actions stop responding.

nearly every time there is an update available and then it responds as normal.

That is very odd... I'm not sure what the relationship would be between an update available notification and network connectivity but then again I didn't design the thing. What is your ethernet speed set to, and is dhcp reconnect turned on?

1 Like

Hub is fixed IP. Never checked/changed a Ethernet speed setting. The hub still responds to web controls i.e. connect to hub via the app / webpage. But the google home integration specifically drops out

Set your google device(s) with a dhcp reservation and see if this corrects the issue.

Ah ok. Ignore my suggestions. Those will only help if the hub itself drops off the network.

1 Like

Digging up this thread because I'm having the exact same problem as the OP.

When it's unresponsive, green light is still solid but none of my automations work, all homekit devices are offline, etc.

The only way I've been able to "restart" the hub is pulling the power cable and plugging it back in.

Then everything is fine for let's say 6+ hours. Seems to be vary but it's been going unresponsive (unable to load web UI and automations stop working) from 1-3 times a day.

I don't know of any network changes, none made by me anyways. I've always run it with a router DHCP reservation and it's plugged into a gigabit ethernet connection. Up until I updated software 5 days ago or so, no problems.

I just tried switching the network settings to "fixed 100 mbps" from auto-negotiate.

Considering I've unplugged it a bunch, do I need to do the soft reset? That doesn't clear any backups, right?

Current platform version is — this probably has been happening on the last few incremental updates since 2.3.6

Thanks for any help, this is driving me nuts!