Hub gets stuck on initialize when joining zigbee devices

I have tried to join three different zigbee devices:

  • Smartthings Button
  • Iris v1 contact sensor
  • Sylvania zigbee outlet

Of course when trying to join the iris v1, I used the iris v1 option on the hub. All three do the same thing, they state initializing and never finishes.

After timing out, I check the device list to see if the device joined just in case. None of the devices show.

Many people report having to do a reboot when this occurs.

Already tried to reboot and problem still exists.

I also changed the batteries in the devices and the problem still exists.

I'm sorry, I should have been more clear....shutdown the hub, pull the power cord, then plug it back in. Reboot does not always reset the radio modules in the hub. They remain powered on during a reboot.

Not saying that will fix it....but worth a shot.

I'll give it a try after the update is done.

Don't forget to shutdown other Zigbee hub if there's any and pair the devices close to the hub if possible.

So like my ikea hub shut down as well?

I would shut it down just in case of interference.

I just joined a iris key fob and it is chatty

Rebooted hub by unplugging waiting three minutes and plugging back in.

Smartthings button joined
Iris v1 still stuck on initialing

I'm going to try more devices but just in case I pulled the battery from the Iris fob.

One Iris v1 contact sensor gets stuck on initialing and the other won't configure correctly to work.

[Edit] both will flash the green led indefinitely

Shows up in the logs though

Try joining the IRIS V1 standing right next to the hub. I had the exact same problem, the Iris V1 units won’t join through a repeater

1 Like

Crazy but yes I had a very hard time with the v1 sensors. They used to pair in place. I had to lay them immediately next to the Hubitat.

The Sylvania outlet us now giving me problems.

So I got everything paired.

Weird thing, I had to bring the zigbee devices in the room with the Hubitat. With the Iris v1, I needed it to be inches away in order to pair.

My devices paired in place just fine before. Is this an interference issue or do I have to worry about my Hubitat radios?

By the way rebooting helped the smartthings pair but not the rest. Definitely needed closer proximity to pair.

The Iris V1 stuff I can explain easily, it just doesn’t work via repeaters.

I have a question for the other problems: Do you have any smart bulbs connected to Hubitat? If so, what kind?


I've also hat the same initialising problem and opened another joining process at the same time, the second instance joining immediately, then just stopped the first

I would be interested to know what actually happens with the HE processes when that happens. Does a second initialize process happen?? @mike.maxwell would you ba able to comment.

This was happening as well. When it just appeared to timeout. I would refresh the page and then two instances would show. When checking the device list though, the new listing wouldn't work.

From what I know, there is only one join process running at a time. Hubitat did change a bit when it comes to the countdown timer. Yes, it actively looks for new devices for 45 seconds but it will continue to try to join a device that hasn’t finished the pairing process beyond that 45 seconds. That’s why devices might finish after the countdown timer is done.

In regard to the second window, I am not sure if that restarts the join process or just piggybacks on the existing one

Oh, and something to keep in mind. Anyone that has joined bulbs to their Hubitat (outside of Sengled bulbs) can expect some kind of problems with other Zigbee devices. Either during the joining process or even afterwards with devices not communication anymore.

Smart bulbs are horrible repeaters and WILL create havoc for other devices like sensors or so