Hub found but unable to connect

My hub is found at an address when I go to myhubitatcom but when I try to connect to it I'm unable to do so. The browser just tried to open the link but nothing happens.

I bought the device nearly 6 months ago but I'm setting it up for the first time. I tried following troubleshooting tips in some of the posts here and on Reddit but nothing worked. I'm worried that my device is a dud :confused: how annoying!

Is the LED Green? If yes...

Try: http://hubitat.local

It's likely your hub has an address, but you don't know what it is. Generally you'll find it easiest over the years to Reserve An Address via your router. Use the MAC address printed on the bottom and assign an address to it. Then, on each future reboot of the hub, the same address will be assigned and you can bookmark it... although "hubitat.local" bookmarks about as easily :smiley:


LED is green and none of that stuff worked. :frowning:

Hi, my hubitat has also a green light on, and it's working fine. Already don't know the diference with blue light on...
You have your HE connected to a router, right? What if you enter in its configuration, to troubleshoot? It should appear. Maybe the problem is in the router side

From your browser can you go directly to the IP?

Did you set a static ip on the hub or a DHCP reservation?

If you can get to it locally in the browser, go to settings>>network setup>>network test and ping , does it resolve or does it error out?

Perform these diagnostics... likely it is a dns issue.

I couldn't fix my network settings on my old router. Got a new one and this seems to be working great.. thanks everyone!

1 Like