Hub (C7) has become so corrupted it wont operate - Not sure how or why

I have an app I can't see now--not sure what happened. But, this is the logged error:

I could recreate the app--but I need to be able to get farther into it so I can see the code (far better to have some portion of a line splatted out with an error that to be totally unable to see it).

Thougthts? What might have caused it?

Possibly related to this:

OK - So, I cannot open ANY of my "Groups" of lights now due to this error.

I rebooted from the Diag panel and it worked for a minute or two

Things went from annoying to totally dead now.

It locked up so bad the diag panel refused to reboot it--so I had to pull the power cord.

It came back up--but I can't start "Safe Mode" (401 error).

It was working for a while after the power-yank. Saw this...seems hosed again (it isn't responding right to my trying to edit a RM4 Rule--it was working, then it quits responding).

You get 401 because your password to the diagnostic tool has expired.
Choose logout and then log back in again.


Whew! That helped @bobbles -- Thx! :slight_smile: Trying safe mode.

In safe mode, I still cannot edit that one Rule.

And I still cannot edit ANY of the groups.

Not sure what got hosed where--but it seems I have a device or something that may have gone missing or something, which is fundamentally breaking things--but I sure can't see what or where.

When I went into the Z-Wave details, it was totally empty--is that expected?

The Zigbee one was NOT empty.

Went in again--took a long time. But it came up (without routes).

I do seem to have a dead/ghost "D4" device.

and this in the log:

Not sure if it's related, or helpful, but I had something similar recently, all of my own making when I produced an endless loop in some of my code. Tried rebooting a few times and the web UI would be accessible for a few minutes and then everything would grind to a halt. Ended up restoring the overnight backup and it was fine after that.

1 Like

I guess I wouldn't want to rule anything out. And, it could be a loop in some other code.

But, all I was doing tonight was adding 4 new devices (and getting ready to delete a failed one).

I didn't think I made any "logic" changes--just device selections.

And, given the "null pointer exceptions", it seems that I've got something deep down that's not set right. Just can't tell what.

Are you still in safe mode?
I've never had to use it so some of the things you are seeing with zwave may be because if that.
I think the next step I would try is shutdown via the settings menu.
When shut down pull the power.
Wait 1 minute and power back up again.
This will get the zwave radio reset, you shouldn't lose your zwave stick configuration.

Since the only thing I've been doing is adding those Inovelli LZW31-SN Red Series Dimmers (4 of them), I am wondering if the driver has gone nuts.

@Eric_Inovelli Any thoughts??? I'm using your latest drivers (on v1.48 of the firmware). on my C-7 Hubitat.

I was really only trying to provide some background to what was happening when mine played up, I assume it could be any number of possible causes. I was probably more offering the refresh from a backup as a suggestion to try and get up and running again. If you can still get in and try and debug it, it's probably worth continuing with that.

Only other suggestion I would make is downloading a stable backup, if you don't do that already. They are only kept for a relatively short time on the hub.

It would be nice to know what each of those apps that are erroring are to see if there is a common device. I think I may make a spread sheet of what app number is what app so that if I ever have an issue like this I have the information handy. I don't suppose that is already out there in one of the backdoor URLs?

@bravenel Who might be able to help me sort out what has gone nuts?

I can't open any of my lighting groups--and at least one rule won't open.

I suspect that whatever thing is hosed up is likely causing this--but I can't tell what the problem child is from the errors. Apps/groups are throwing serious errors ("null pointer exceptions" typically), but that problem prevents me from even opening up the item at hand to see what might have it upset.

I'm really dead in the water now--it's been "running" in Safe Mode--but nothing works, so that's def not something desirable. And, the Groups and that App still throw the error--so the error seems to be in a device, app, something???


Never have been in safe mode so this may be a dumb question but is it like checking all the disabled boxes? Could you one by one turn them back on until you see the bad behavior begin? Can you restore a backup from before you started having the trouble? Just tossing some ideas out there until someone with a more definitive answer happens to pass this way.

I would try a soft reset and restore from a recent backup. You might have some sort of database corruption.

I encountered strange errors once’s and a soft reset and restore fixes things for me.

It's an "all or nothing" flag on the diagnostic web page.

Given that I still have something throwing null exceptions, there's something wonked up deeper than the apps.

What is the impact of a "soft" reset and a restore from the previous backup?

Trying to avoid a situation where I have to figure out how to create zillions of rules and re-include 50 devices.

A soft reset and restore should return it to exactly the way it was at the time of the backup. Everything should be intact afterwards as a soft reset does not remove the zigbee or z-wave radio configurations. All devices, apps, drivers, settings etc will be restored.
Once the protection service is available for purchase that will also do all of the above as well as backing up the zigbee and z-wave radio configurations which means you will be able to do a hard reset and restore or even restore to a new hub entirely.

1 Like

Since I'm seeing errors with things like the "Group" function (null pointer/unable to open), that seems to indicate something deeper is confused.

I'd like to know what's wrong--if it is a specific device, etc. or what?

Restoring the apps doesn't seem likely to fix all that??

There shouldn’t be any impact, the soft reset will clear out the hub’s database but not touch the radios, giving you a clean slate. You would then restore the hub with a recent backup, which would restore all your rules and other configurations. Depending on how old your latest backup is will dictate what is restored (there should be nightly backups).

Give the wiki a read it walks through those steps and you can gauge your level of comfort.

Those sort of errors sort of point to some sort of underlying corruption at least to my uneducated eyes, but I’m definitely not an expert. If it is corruption, you are probably unlikely to ever know what exactly triggered it.

Perhaps @gopher.ny is around and able to take a peak to see if anything stands out to him...

1 Like

I suppose I'm less concerned about what is wrong--than in fixing it with the least disruption possible.

Which is why I'm hoping someone can get back to me on that.

If those errors were trapped and would provide a bit more information about what was happening when the exception occurred, it would be especially helpful. :slight_smile: