Hub C7 firmware update of hubitat

Hi, is there any reason my C7 won't update its own firmware?
Its been a couple of years since i messed with it but i have need for it now and need to learn to to use it.
So far ive tried 2 different PC's, two different browsers, disable my firewall and pi-hole and its been checking for an update for an hour. The logs are dated 2021 which would be the first and last times it was used but i cant seem to get any new ones.The current FW is

Use the Network Test tools in Network Setup to rule out a cloud connectivity problem (maybe DNS), which might cause your problem:

If that fails, you know what to fix. As for how: you could try a network reset (also documented in that page) or, if you suspect DNS, making sure they are set correctly if you aren't using DHCP or that your network itself is set up correctly (anything else odd besides PiHole?).

Thanks for the tips. The only network test it fails is the speed:--2023-04-30 19:21:14--
Resolving failed: Temporary failure in name resolution.
wget: unable to resolve host address ''

Ive just tried the other update method and that has also failed. I DO suspect the Pi-Hole but not a single other item on my network has had an issue.

Sounds like DNS isn't working. Did you try the network reset?



:point_up: This.

Or manually configure DNS for the hub to be or (or both, ","). Basically, so it uses something other than the PiHole for DNS,


Right, again, thanks!
It passes all the network tests except the speed test and when i go to, the file downloads but IF i go to then my laptop just says the page should be playing a flash movie. Also, NSLOOKUP works as it should.

I cant see a network reset, unless you are referring to the DHCP swap. Yes, i have tried that. Ive unplugged the wifi dongle so its ethernet only.
Ill try configuring the hub dns although i'm sure ive already done that.
Would be helpful to know the address of the update server then i could NSLOOKUP that and see if i can actually contact it.

Hubitat Elevation Update Tool also fails to update (or connect).

Did you try pinging a hostname rather than an IP address? What was the result?

This procedure is described in the document I linked to above (button on the bottom of the hub).

Keeps sounding like DNS to me. You can manually set them to something valid, but after a reset (which will, among other things, revert to DHCP), it should also work unless you have odd network setup at home.


Server: pi.hole

Non-authoritative answer:
Addresses: 2a00:1450:4009:822::200e

Ah, right, will try that reset now.

Folks, thank you.
The network reset did the trick!