HTTP 404 Error - App links corrupted with regex

I've recently installed my Hubitat Elevation and from the get-go I've had a very strange problem with the Apps. Clicking any link to any App sends me to a 404 Not Found page with a very strange URL that looks like an improperly escaped regex. The URL I'm sent to is:^[%20/t/r/n/f]+|[%20/t/r/n/f]+$/g

As a result I'm not able to actually using any Apps.

I've been through several software updates over the last couple of weeks that have had no effect. I've tried a soft reset, and a hard reset, all to no effect.

I know from doing some reading on the forums that the Hubitat folks have a lot on their plate right now, so if anyone has any thoughts on what might be causing this I'd really appreciate your input.

Hubitat Elevation® Platform Version

Hardware Version
Rev C-5


You should contact support directly at That will register your issue and get some help.

1 Like

I would try a different browser, no such regex like that exists on the hub. I am suspecting a browser plugin or something else causing this issue. What browser, device, etc are you using?

I have contected support by email a couple of times and am waiting to hear from them.

If you have not received a confirmation email with a ticket number from support then they may have problems with your email address (seen this before). If you do have a ticket number you can PM @bobbyD directly with that number.

Btw, @patrick that replied above is the best support you are going to get besides Bobby. Please look at his reply and respond to his feedback.

I normally use the latest Safari on Mac, and I did try on at least one other browser (not sure if it was Firefox or Chrome.

Several updates came out over the last week and I applied them all. Hadn't heard back from support (email problems I guess) so starting from scratch seemed like a good idea. Appears that process may need some tweaking to make it a little more robust.

Thanks, I'll try reaching out from another email address.


Hi there, please check your private messages. I sent you one a few hours ago. You should have a green dot in the upper right corner, click on it, then click on the message from me.

Was there ever a resolution to this?

I am using an old iPad 4th generation running iOS 10.3.3 and had the exact same issue (Safari and Chrome v71) - the "newest" allowable versions. Of course I could go onto my new devices and obtain the direct dashboard links and manually type in the URL, but it's kind of a pain.

I am using an old iPad as well and this is the same URL that I'm getting (different IP of course) as well.

Getting these 404 errors when I try to go to the dashboard on this iPad.

I had the exact same problem on my iPad last summer right after a hub firmware update. But it worked fine on my Mac. I updated the iOS level on the iPad and it worked ok then.