HSM arms away at random while prescence sensor is present

Hubitat Safety Manager keeps arming randomly while my prescence sensors are home! I cannot seem to find any details in the logs. This happens without any input from me what so ever! Previously while echo speaks was connected to alexa guard it would start an infinite loop of arming both hsm away and alexa guard. Disconnecting it seems to have stopped the loop so far but HSM away will still arm without warning at random, does anybody know what could be causing this?

Hi @brettbaillie,

Are you able to provide us with screenshots of your HSM configuration screens? That would help us provide assistance. There should either be something in there, or there could be a Rule that is changing HSM. If you have rules that impacts HSM, please also include screenshots of those.

Also, welcome to the community!

Thanks Sebastian here is the rule I use to control hsm. I use virtual switches for easy integration with alexa and google home, the switches are disabled in alexa hunches too!


IF (HSM Switch - Away(off) is on(F) [FALSE]) THEN
HSM Arm Away
Mode: Away
On: IP Camera 02: Kitchen Switch, IP Camera 01: Lounge Switch
Off: HSM Switch - Night Guest
Pause Rules: HSM Switch - Home Deactivate Hall Motion Sensor (paused), HSM Switch - Night Deactivate Bedroom Motion Sensor (paused), HSM Switch - Night Guest Deactivate Bedroom Motion Sensor (paused), HSM Switch - Night Guest Deactivate Spareroom Motion Sensor (paused)
ELSE-IF (HSM Switch - Home(off) is on(F) [FALSE]) THEN
HSM Arm Home
On: IP Camera 02: Kitchen Switch
Off: HSM Switch - Night Guest
Resume Rules: HSM Switch - Home Deactivate Hall Motion Sensor (paused)
Pause Rules: HSM Switch - Night Deactivate Bedroom Motion Sensor (paused), HSM Switch - Night Guest Deactivate Bedroom Motion Sensor (paused), HSM Switch - Night Guest Deactivate Spareroom Motion Sensor (paused)
ELSE-IF (HSM Switch - Night(off) is on(F) AND
Variable Guest Present(false) = false(T) [FALSE]) THEN
HSM Arm Night
Mode: Sleep
On: IP Camera 02: Kitchen Switch, IP Camera 01: Lounge Switch
Off: HSM Switch - Night Guest
Resume Rules: HSM Switch - Night Deactivate Bedroom Motion Sensor (paused)
Pause Rules: HSM Switch - Home Deactivate Hall Motion Sensor (paused), HSM Switch - Night Guest Deactivate Bedroom Motion Sensor (paused), HSM Switch - Night Guest Deactivate Spareroom Motion Sensor (paused)
ELSE-IF (HSM Switch - Night(off) is on(F) AND
Variable Guest Present(false) = true(F) [FALSE]) THEN
HSM Arm All HSM Rules
Mode: Sleep
On: IP Camera 02: Kitchen Switch, IP Camera 01: Lounge Switch
Resume Rules: HSM Switch - Night Guest Deactivate Bedroom Motion Sensor (paused), HSM Switch - Night Guest Deactivate Spareroom Motion Sensor (paused)
Pause Rules: HSM Switch - Home Deactivate Hall Motion Sensor (paused), HSM Switch - Night Deactivate Bedroom Motion Sensor (paused)
ELSE-IF (HSM Switch - Night, HSM Switch - Away, HSM Switch - Home(off, off, off) any is off(T) [TRUE]) THEN
HSM Cancel All Alerts
HSM Disarm All
IF (Mode is Away(F) OR
Mode is Sleep(F) [FALSE]) THEN
IF (Time between Sunrise and 12:00 PM ACST(F) [FALSE]) THEN
Mode: Morning
ELSE-IF (Time between 12:00 PM ACST and Sunset(F) [FALSE]) THEN
Mode: Afternoon
ELSE-IF (Time between Sunset and 10:30 PM ACST(T) [TRUE]) THEN
Mode: Evening
ELSE-IF (Time between 10:30 PM ACST and Sunrise(F) [FALSE]) THEN
Mode: Night
END-IF
END-IF
Pause Rules: HSM Switch - Home Deactivate Hall Motion Sensor (paused), HSM Switch - Night Guest Deactivate Bedroom Motion Sensor (paused), HSM Switch - Night Guest Deactivate Spareroom Motion Sensor (paused)
IF (Variable Guest Present(false) = false(T) [TRUE]) THEN
Off: HSM Switch - Night Guest, IP Camera 01: Lounge Switch, IP Camera 02: Kitchen Switch
END-IF
END-IF


Here are the settings for hsm away.


Hope this helps!

Is there something that could trigger the “Away” or “Sleep” modes? Is there anything that could be pressing on one of your “HSM Button”s?

The HSM Button is virtual I only use it for dashboards, but I think I may have found the culprit!
I didn't include my geofence rule because I've paused it in the past and it hasn't stopped the arming loop. I realised this morning that because the geofencing rule had already started the loop with alexa speaks that pausing it wouldn't stop the loop. So I'm going to change that rule from this...

to this...

And hopefully the problem will be fixed!

1 Like

Pretty sure it's a problem with OwnTracks which I use for geolocation because I've noticed it sometimes shows me as miles away from my current location when I'm in an intermittent signal area!

1 Like

Download the Hubitat app