How to import a saved rule

in latest s/w how do i import a rule from a saved file.. i dont see the options any longer in rule machine

found it in the menus but it fails.. just a constgant flickering screen

now hub is stuck constant refreshing this window

rebooting now but urgent cannot event get into rule machine legacy.. now if i click on it i just get this ..

i tried creating just some new bogus rule. worked ok. but going back to rule machine legacy still just get that window..

hopefully reboot will fix.


Do you have a good backup that you could revert to if it doesn’t work? I have run into an issue several platform version back where I was stuck and was able to get back to normal with a restore. I might have lost a few changes, but they were quick to re-create.

reboot fixed it.. thanks but yes i have multiple backups

i gave up trying to import that rule and bit the bullet and just modified the existing one.. it had 15 button actions so was a pain. all custom actdions with an actuator..

now in the latest i no longer see the backup/export for rules.. mayhbe it was removed as not working correcdlt? found it again under the rule machine settings

You should read this:

ya thanks.. but still doesnt explain why when i tgried to import a rule it went in a loop and hung.. i can send you the rule file off line if you like let me know how to post it.