How to get notifications

So this looks like the same problem I am having - with additional details...
Set up notifier to my generic Zigbee contact sensor (ThirdReality Zigbee contact sensor) on the garage door. Sensor reports correctly in the device just fine. Set up rule to send notification to my phone (with the Hubitat app installed) but no notifications appear.
Sidenote 1 - in the app, when I click on "Tools -> notifications" all I see is a spinning wheel of death, waiting for eternity to come to pass.
Sidenote 2 - Uninstalled and reinstalled the app... or at t\least trying to now... and at the initial login screen, I am stuck on "Fetching users data" with that same too familiar wheel of death :scream: :skull: :ghost: !

UPDATE: Finally got the app to open, wheel never went away, I just closed and reopened it and VOILA! my interface was there. However, going to "Tools -> Notifications after sending a test notification in the phone device page still yields the little red death spiral!
No notification came through for my phone.
NEW GLITCH: When I go to "Devices" all I get is a little green house in a tornado (another different-colored wheel of death...
Before you ask, App version is 1.6.8., build number 128

FURTHER UDPADED: I went to connect to my Hub from my phone, and I get ERRORS:
The first attempt was " okhttp3.ResponseBody$1@73e75a7 "
clicked OK and tried again, got: " okhttp3.ResponseBody$1@87e1891 "
This is completely Greek and not very helpful to me... :woozy_face:

@moncho1138, Macguyver above is getting some weird errors on the phone app.

@Macguyver I don't see if you are using iOS or Android, it probably would help if you could list that.

My bad, Android on Samsung S21

Everything app is completely broken.
Open the app, IF the login screen appears, I enter the correct username and password and it says "fetching user data"..... Forever!

If I try to register hub to the app, it says "no hub is associated to that email account"

I can use the app's internal browser to find my hub and see everything, but if I then back out to the main screen then click on "devices" tab at the bottom, I just get the spinning wheel of death.

I can log in with Chrome on Android but if I click on "registered hubs" it takes me to "" and tells me that there are no hubs associated with the email.

From there, if I try to find hubs, it just keeps searching, and yes I am on the same 2.3G local network.

I'm lost and need help!

Can you reach the hub via a regular computer browser? If so, completely remove the app. Restart your phone, reinstall the app. Go to settings then hub. PIck up. (make sure you're on LAN not 5g)

1 Like

Yes @rlithgow1 , I can access the hub both on my laptop or my phone using the ip address just fine. I had already uninstalled and reinstalled, but did not restart between those steps. trying that now.

Also tried going to on pc and also says no hub associated with the email.


1 Like

So I have removed/uninstalled the app, restarted the phone, and at 0912 entered the login information. = "Please wait... Fetching users data"

0922 now and still "fetching"....

0934 still fetching. Reminds me of a dog I used to have like this. Id throw a stick and say "Fetch" and he'd look at the stick... look at me... look at the stick... then lay down.

1 Like

Never stopped "fetching" but I think that is just a hiccup in the app not transitioning to the next item. I exited that screen then revisited it by clicking on the app icon, and it was at the brief tutorial page. For grins, i went through it, made sure to allow positions and for all the time at precise level, then it put me at the dashboard tab - which was blank white.

I clicked on the Devices tab in the bottom center and it says "Hub is not responsive, please make sure it is online and connected to the cloud" Not sure where to check that, but if it is not, it won't be able to communicate with my phone for door notifications when I am off the LAN.

I totally agree that those errors are meaningless, the next version of the mobile app will address this problem. What that means is that your hub is no longer connected to the cloud.

This is also a side-effect of the fact that the hub isn't connected to the cloud. Here is a post from yesterday of someone else who had a cloud connection problem:

Push Notification service requires cloud connection, so you will not be able to receive push notifications if your hub isn't connected to the cloud.


So @bobbyD and @rlithgow1 , seems you guys are pretty savvy on what might be my issue.
I rebooted the hub to see if that would fix anything, but no.

Followed the linked thread above from Bobby, and in my network properties, I find the DNS is set to and , so, I go to my router setup (Netgear c6300) and I find DNS set to "get automatically from ISP" (Comcast/Xfinity). I went to change it to second, and third, save and POOF! No more connection... Nothing connects at all.

I reboot the Netgear C6300 and it resets to Auto DNS and connects with the old DNS server numbers.

I search this on Google, and learn that is a Cloudflare product, which sounds very good, but requires some installation tool? At this point I am reticent to install just because I don't want to break anything any further! Please help!!

the 75.75 stuff is from comcast. At this point with a toothpick or paper clip press the reset button on the bottom of the hub (the only round hole out of all the squares). This will reset your network settings. Set a DHCP reservation up in your router for the hub. See if it can reach the internet now.

1 Like

Well, it is improved!
Reset via the hidden switch, already have a reservation in the router and it found it just fine. In the router settings page on the PC I see the DNS is set to, and I set the default gateway to the IP of my router (, and at this time the app did connect - partially.

I first saw no dashboards, and only two devices (Shelly Dimmer-2's) in a single room. I went to the app manager and cleared cache, now I see all four of my Shelly dimmers, but I cannot see my ThirdReality Zigbee Door sensor. I do see the "Garage" room I set up, but no device in that room - Ironically, it is on my "All devices" dashboard, and when I activated it I DID GET a notification!!! :smiley: :man_cartwheeling: :man_dancing:

Don't change any of the setting on HE, let it run full DHCP and see how it performs

Now, shut down the hub via settings. Unplug (at the wall not the hub) for 5 mins and power back up. Then see how everything is. And for giggles, lets see your z-wave details page in it's entirety...

1 Like

So here's the Zigbee details, looks pretty generic. I'm just starting to build my system from the ground up after Insteon was bought by the J. Epstein Group... :dizzy_face:

Rebooting now...

z-wave details page

I have no z-wave devices?

Oh.,.. I was under the impression you had devices on this hub. Is this just a secondary hub running rules?

It's the only hub, just slowly populating it from scratch as I learn all things Hubitat.

Currently I have 4 Shelly Dimmers, and the one door contact (three purchased) installed and setting up for routines.

I do have a minor issue with the dimmers, slow fade to zero stops at 1% glow. I can start a new thread with that, I think that would be best.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.