HousePanel Dashboard App for Hubitat


#343

Version 1.926 posted with docs update and a help button. Pretty cool analog clock update too. Longer post described over on the ST forum.


#344

Okay good people!!! I hope you all enjoyed the blast of serial updates to HP. That is what happens when I have a week away from work. The last post is Version 1.927 with all sorts of goodies and tweaks. I hope you all enjoy. I won’t be updating again for a while since I’m now back to work and focused on those things. Please collect up any feedback and wish lists for the next time I have a few days to spare - should be right around Christmas time.


#345

Damn, You have been on a roll ken, I have not been able to keep up. Looking forward to testing all these new tweaks.


#346

Is Hubitat still broken when trying to OAUTH? Is there a workaround to authorize HousePanel with Hubitat 2.0?


#347

I was able to authorize HP using the oauth.cloud.habitat.com URL set as API Url, but even though I can successfully authorize all my devices and HP successfully saves hmoptions.cfg, it just stays at that page and never renders anything.

I do have CURL enabled.

Any thoughts?


#348

Did you click the bottom most button to say Done authorizing?


#349

Yea, I was off work for a whole week and had tons of free time. Hope you enjoy.


#350

Yeah, it reloads the same page


#351

Hmmmm shouldn’t do that unless it didn’t authorize properly. A few things to check:

  • did the access code and end points get loaded in the gray boxes?

  • after authentication did it tell you how many devices were authorized?

  • did your hmoptions file get updated?

  • open a log window and repeat the auth.. does it show the devices being loaded?

If all above are yes and it still happens let me know because then it must be a bug. Then again it is working for me.

One other thing - a better workaround that will also work is to manually enter the access and end points from the log after you save the app. Be sure to unselect cloud so you get local access.


#352

Thanks a lot @kewashi ! I was trying to make it work from a VPN at my work and apparently something was not working as expected. When I got home I was able to make it work.

Do I need to keep the Cloud endpoint or is it safe to change the config file to use my hub directly?


#353

if you change to use your hub directly you will have to change the access code and endpoint to match. To get those just open a log window and then in a separate window (or on your phone) open the Hubitat main page and load the HousePanel app, un-select cloud, and then resave it. This will display in the log the access code and end point you need for using HP via a local hub.

None of this nonsense will be needed if they fixed the local OAUTH flow but this workaround does work.


#354

The oauth page is fixed in the next release.


#355

@kewashi I have the MyQ Lite app to control my garage door, and HousePanel creates a tile with a lamp (switch) and a garage door. I'm trying to get rid of the switch so I have only the garage door but I can't figure out how to do that. I can make the lamp disappear but the garage door will never move to the front of the tile if I resize the tile.

Any thoughts?

22%20AM


#356

"Hide Element", duh !!!

Dude this thing is awesome. Great job!


#357

@kewashi it looks like HousePanel and Hubitat are still not doing the OAUTH thing properly in local mode.
Tried with 2.0.1 and even though it doesn't 500 anymore, when trying to re-auth and use my hubitat IP instead of the oauth.cloud.habitat.com address, I get a huge authorization page with all my devices repeated many times. I tried to select a few and proceed, but it won't complete after the "Done" button is pressed.


#358

There is a new issue. Looking into it now.


#359

Thanks Patrick for following up. Just wanted you all to know that nothing has changed in the house panel authorization code so I don’t think there’s anything I can do on my end to help


#360

Yes, a hotfix will be pushed out once it's through testing.


#361

@patrick did 2.0.1.114 fix this issue?


#362

YES!!! It finally works locally. Thank you!!