Honeywell t6 setting time through a Rule

When I pull up my Honeywell T6 Z-wave device; I am given the option to set the time. I want to be able to set the time every night to keep the time in sync.

In actions I am choosing "set variable, mode or file, run custom action" >> "Run custom actions" >> "thermostat"

I want to set it with the hubs time but after choosing "setclocktime" I have to choose one of three options "string, number or decimal".

Does anyone know how I could solve this?

I've never seen a clock on mine... That said, I have enough clocks in the house and HE controls the thermostat based on its own time...

I do not disagree but if the device has a clock I want to keep it accurate. I install this in many homes so I am trying to put a model together.

You are going to want to choose number I believe.. That said I don't see a setclocktime attribute within the T6 Pro's exposed attributes. Where do you see this at? (Just curious) Also what driver are you using?

This customer is in Canada so you will see Celsius but you can see the Set Clock Time. Which works perfectly. I just want to automate that.

1 Like

FYI, from that screenshot, the custom command setClockTime takes no arguments.

This doesn’t look like a built-in driver. Is it @bcopeland’s older driver?

If I click it, it works?

1 Like

Exactly!

That command takes no arguments. You don't need to pass along a string, number or decimal value along with the custom action "setClockTime" in Rule Machine. Just ignore those options.

And, there's nothing wrong in using an older driver as long as it is still functional.

Edit: I would add that if I were setting this up on a client's hub, then I would feel most comfortable using built-in drivers - to avoid any unexpected surprises if there are changes in z-wave handling after a platform update.

1 Like

I will try that

It worked perfectly!!!

Thank you

1 Like

Download the Hubitat app