Homebridge Plug-in


#163

Thanks! I also wasn't sure about the capability names themselves, but as with many undocumented features involved with the development of Hubitat apps, I figured the ST docs were close enough. :slight_smile: I'll try the Hubitat device "ID" (I'm guessing this is the same you see in the URL, but I'll check the logs to be extra sure...) and hopefully have better luck. Thanks again!


#164

My pleasure!
I just checked the device URL and you are right! Its the same DeviceID that the logs show. Thanks for pointing this out. Not sure how I missed that...I'll update my previous post for others to see too.


#165

@tonesto7 - I want to disable the debug logging for device register when not needed. Can I just comment out just the debug lines like this? Do I also need to comment out registerChangeHandler?
Sorry to ask and not just try, but I'm gun shy with changes to Homebridge. Finally have it working in harmony with everything on my hub and so I don't want to throw a wrench in the works (or a spanner if you prefer).

def registerDevices() {
    //This has to be done at startup because it takes too long for a normal command.
   // log.debug "Registering (${settings?.deviceList?.size() ?: 0}) Other Devices"
	registerChangeHandler(settings?.deviceList)
//    log.debug "Registering (${settings?.irrigationList?.size() ?: 0}) Sprinklers"
    registerChangeHandler(settings?.irrigationList)
}

def registerSensors() {
    //This has to be done at startup because it takes too long for a normal command.
//    log.debug "Registering (${settings?.sensorList?.size() ?: 0}) Sensors"
    registerChangeHandler(settings?.sensorList)
//    log.debug "Registering (${settings?.speakerList?.size() ?: 0}) Speakers"
    registerChangeHandler(settings?.speakerList)
//    log.debug "Registering (${settings?.shadesList?.size() ?: 0}) Window Shades"
    registerChangeHandler(settings?.shadesList)
}

def registerSwitches() {
    //This has to be done at startup because it takes too long for a normal command.
//    log.debug "Registering (${settings?.switchList?.size() ?: 0}) Switches"
	registerChangeHandler(settings?.switchList)
//    log.debug "Registering (${settings?.lightList?.size() ?: 0}) Lights"
    registerChangeHandler(settings?.lightList)
 //   log.debug "Registering (${settings?.fanList?.size() ?: 0}) Fans"
    registerChangeHandler(settings?.fanList)
}

#166

Just the debug lines will be fine


#167

Just updated HE platform to 1.1.7.118 and now getting continuous "connection error" from Homebridge-Hubitat app

App version is 1.1.6b and Plugin is 1.5.2

I have removed the plugin and reinstalled, as well as refreshed the Oauth and verified the config.json file is correct and has the updated info. Everything working, but it is generating constant warnings. If I remove every device, they stop, but if I add just one device (no matter what device it is) the warnings resume. The more devices I add, it seems the faster the warnings, so I assume I'm getting one for every device I've added.

Again, it's publishing in HomeKit and I can control devices, but it's just generating a steady stream of warnings.

Any further data I can provide to help troubleshoot?


#168

+1 I am seeing the same issues.


#169

I'm not. :frowning:

Homebridge is working for me on 1.1.7.118

I just asked Siri to turn on and then off the light in this room and it did indeed work.

I'm on Homebridge v1.4.1


#170

I'm not seeing any issues, either, with firmware 1.1.7.118, homebridge@0.4.45, and homebridge-hubitat-tonesto7@1.5.2.


#171

connection refused... if that's to the homebridge server, then maybe review OAUTH ??


#172

I'm not seeing any warnings in my logs.


#173

Mine is fine as well.


#174

Same.

I refreshed OAuth. Even removed the app, reinstalled and refreshed OAuth again. To be clear, Homebridge it is still working, just generating a ton of warnings that I didn't see until 1.1.7.118 and now I'm at 119


#175

You were newer Homebridge than me.. between my last message on this and now, I've upgraded both Homebridge on my Mac and Homebridge app to Tonesto7's latest.

Not change to my experience. Still not getting any problem with the error message.


#176

Ah, silence. Looks like I forgot to check this box the first couple of times. Pays to get some rest, which I will do now. :smiley:

32%20AM


#177

Excellent find.. I never even noticed that before. Oauth has always been something I click through as fast as my finger goes.


#178

I've been holding off on upgrading as I am on the other side of the country. Now that there's a solution I'll give it a shot. Thanks team Homebridge!


#179

There is an issue to be aware of. Get your configuration and then DO NOT LOOK AT IT AGAIN!. I set everything up, and then double-checked my configuration in the Hubitat-Homebride app and that deselects all devices.

So then you lose all your device in HomeKit. So if you've spent the time to move everything into rooms, you will lose your HomeKit room setup if you happen to click on configuration in the Hubitat-Homebridge while Homebridge is running. You can backup to Persist and Accessories directories in Homebridge to avoid this, but this is something I had not done for my recent configuration unfortunately.


#180

Is this a bug or something that has to be done if I ever want to modify the configuration ever again?


#181

Issue :smile: I don't want to call it a bug, because it worked fine before the HE upgrade, so I would classify this as a compatibility issue that need addressing. Nothing wrong with @tonesto7 (Tony's) coding. Just needs an update is all.

Getting the configuration settings from the app is not typically something that has to be done again once setup. I refreshed my OAuth to resolve the stream of warnings I was getting after the latest HE release, and so I clicked the configure link in the Hubitat-Hombridge app to verify it was the same, which led me to discover the issue.

If you backup the Persist and Accessories folders in Homebridge, you can just replace them with the backup if something like this occurs and your HomeKit configuration will be restored. Just hadn't done that before clicking the link unfortunately.


#182

Interesting. I agree, not a bug on @tonesto7 's end.

I have an iOS app called Controller that claims to backup Homekit. I'll try both methods.