Homebridge MakerAPI getting no response warning, but it works?

I've installed MakerAPI app on hubitat and installed homebridge, plus homebridge-config-ui-x as well as the homebridge hubitat makerapi 0.4.11 npm package. My homebridge starts - logs look clean - but my home.app shows "no response" on all my devices. If I click on a device, it polls and gets the current status of the device I clicked on, and a second click will toggle or let me interact with the device successfully. But why won't it update and provide easy access like it was doing prior to my hubitat hub update yesterday?

I'm not sure when this "no response" error came about - I usually just talk to Siri and she does the deed (still works that way first try usually) - but it seems like polling device status is broken now and I'm not sure why.

I completely erased homebridge and started over from scratch today since my install was half a year old and I thought perhaps the update of my hubitat yesterday required a newer version or such of the homebridge side of things. The problem with running homebridge on my raspberry pi 4 is that I set it up so long ago and my notes I took while doing the install don't help me troubleshoot much.

Google results say to disable multiple hubs - but I only have one apple TV3 and one Apple TV 4 and I've disconnected the 4... (3 doesn't work as a hub I don't think) and it still doesn't work.

I am using hubconnect but also have the same issue whenever Hubitat got rebooted. Restarting homebridge does the trick for me so I end up just adding a rule to restart homebridge on the systemStart event.

Try stopping homebridge and then remove your “Persist” and “Accessories” directories.

cd .homebridge/
sudo rm -r Persist/
sudo rm -r Accessories/

Then remove the bridge from HomeKit in the Home App.
After doing this Start HomeBridge and then add the Bridge accessory.

I don't have the .homebridge/ folder in my user's home folder anymore. I removed all of that and used the steps to install here:

That site provides the config-ui-x plugin and also a auto start service which made things a lot more simple for my feeble brain. The directory structure is now /var/lib/homebridge/ and I did as you instructed with the removal of the persist and accessories folders. When I added the accessory back - I got a million prompts for each of my devices to place them in rooms, etc. I had my home.app open on my mac and as I went through each one they showed up properly and they are still responding and updating as we turn on lights around the house.

But I just opened home.app on my ipad and they all show no response still.

After a few minutes I went back into my iphone and it now shows no response as well. But my home.app on my mac still is getting live updates and responding properly.

Have you tried restarting your iPad?

Yep - rebooted my phone and ipad - neither get responses until I click on the device, then it refreshes and shows the current status. I can then toggle the switches on and off, etc...

Siri still works first try usually.

Home.app on my mac still shows live responses and updates when I press a physical lightswitch to turn them on and off... I'm stumped.

If you go into the home settings on your iPhone does it list your iPad as your home hub and show the homebridge bridge?

I have my apple TV 4 listed as a Home Hub (connected) and the only bridge I have is my Homebridge. (singular)

I have tried disconnecting the ATV4 and rebooting everything with the same results. My ipad does not show up in that list.

OK, you've got me stumped... Maybe @dan.t or someone else can jump in to help you out.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.