Home Assistant Device Bridge driver problem

@tomw @ymerj

After migration from C7 to C8 I am trying to keep C7 for all LAN-based integrations.
HADB is one of the LAN-based integration I am using.
The problem happens with Ecobee Thermostat. It has local integration on the Home Assistant
but I want it bring to the HE. On the C8 (after successful migration from C7) everything looks
good. Here is a reported Current States from C8:

However on the C7 (I reinstalled HADB from scratch) Thermostat Device is missing a lot
of things. Here is a reported Current States from C7:

I tried to initialize a driver but this did not help.
Reinstalling the entire integration will be very painful because there is no easy way
to deal with Child Devices and I already switch a lot of the from C8 drivers to the C7.
I am using Hub Mesh to bring devices from C7 to C8.

Any ideas what could be wrong and how to fix this issue?

Has there been a change in thermostat state for those attributes after you set up HADB on the C-7?

C7 reports bogus Current Thermostat States.
C8 seems to be still OK and happy.

HADB installation on C8 is migrated from the C7
HADB on C7 is very fresh, done by using HPM, and after C7 was basically Factory Reset.
Right now HADB runs on both hubs in parallel (this should not be a problem, I asked @tomw this question before doing this). My goal is to keep all LAN-based integrations on the C7 and bring all devices to the C8 via Hub Mesh. Migrating these Child Devices is a very real headache (must be carefully done one-by-one). So far was everything was good but I stepped into Thermostat Device problem. On the C7 states are incorrect. Of course C8 also is getting incorrect states.

I'm not sure I follow. Witch one is it?

  • C7 was migrated to C8 very successfully;
  • HADB is very happy on the C8 after migration from C7;
  • Fresh installation of HADB on the C7;
  • Now C7 reports wrong Thermostat States;

Currently HADB runs on both hubs in parallel. I need this in order to swap all these Child Devices one-by one. So far 27 out of 28 devices already migrated. But I cannot migrate Thermostat because on the C& states are incorrect no matter what i tried in order to fix this
(multiple C7 reboots, changing Generic Thermostat Driver to Device and back, pushing Refresh button, stppping/starting Parent Driver).

The null values means nothing was return by HA for them. Did you try to set a different setpoint to see if they will populate?

1 Like

No, but periodically these null values are correct.
BTW, once in a while C8 is also reporting NULL values randomly.
However "supportedThermostatFanModes" and "supportedThermostatModes" states NEVER showed up on the C7. And this is a BIG problem as we speak.

The built-in generic component thermostat does not provide a mean to set the supported modes. As a workaround you can set the child driver to generic thermostat, then set the appropriate modes and return it to component thermostat.

1 Like

Well, I am not sure what was done in my original setup (now on thee C8) but I tried your suggestion. Generic Zwave Thermostat driver did not work but Generic Zigbee Thermostat driver did the trick:
No I see the same stats on both hubs.
My question is : Is this a REAL fix and everything will work?
I will test this shortly.

And is it possible to fix Component Generic Thermostat driver or this is HE built-in one?

This is the buit-in one.

1 Like


BTW, right now states on C8 reported NULL values and became and "supported*"
sates are different on C8 and C7:
Here is current C8 states:
And here is current C7 states:

So why once in a while NULL states are reported?
Can this be fixed if this is a problem?

Ok my bad for the difference between c8 and c7 supported modes. I should have said virtual thermosat as a temporary means of setting modes. With this one you can set the supported modes as you like.

The null values are showing there because your thermostat is OFF. This can be change in the next update of HADB.

OK, Very BIG Thank You for very quick solving my problem.

Just in case I deleted a Child Thermostat device and change driver to the Virtual Thermostat
but this did not bring in "suppored*" states:


I guess, it should be OK if I use temporary Generic Zigbee Thermostat driver.

There are commands in the virtual thermostat to set those supported modes. You have to set them manually.

Where do I find these commands?

Just edited my previous post... Anyway, HADB does not use these but other app may need them.

Download the Hubitat app