HEM v5

After removing the device from HE, added it back in (came in as a "device" and had to manually select the driver),now it seems to work! Thank you. Thank you! My wife thanks you for her drier notifactions

EDIT: spoke too soon... not getting separate "clamp" current readings and the following errors in the log

this is the device in case it helps.

Without a device, I really cannot assist too much more. I did look at the line numbers for both of those errors.

The first error has to due with some sort of 'energy' cost reporting info. Did you fill in the user preference setting for your energy costs?

		input "kWhCost", "string",
			title: "Cost in \$/kWh",
			description: "Your Electric Bill Cost Per kWh",
			defaultValue: "0.19514" as String,
			required: false,
			displayDuringSetup: true

The second one, seems to be related to the fact that you may not have configured the settings of the device fully. The error is due to the fact that 'monitorInterval1' is null.

I recommend you configure the user preferences appropriately, save the settings, and then click CONFIGURE to see if these errors goes away.

		input "monitorInterval1", "integer",
			title: "Group 1 Reporting Interval (Total: Watt,Voltage,Amperage,kVarh,kVar)",
			description: "Interval (secs) for parameter 101",
			defaultValue: 60,
			range: "1..4294967295?",
			required: false,
			displayDuringSetup: true
		input "monitorInterval2", "integer",
			title: "Group 2 Reporting Interval (Watt, kWh for Clamp 1 and Clamp2)",
			description: "Interval (secs) for parameter 102",
			defaultValue: 30,
			range: "1..4294967295?",
			required: false,
			displayDuringSetup: true
		input "monitorInterval3", "integer",
			title: "Group 3 Reporting Interval (voltage/current for Clamp 1 and Clamp2)",
			description: "Interval (secs) for parameter 103",
			defaultValue: 6,
			range: "1..4294967295?",
			required: false,
			displayDuringSetup: true
1 Like

Well that fixes the reporting, but breaks the rule (white screen) and the error below

Completely understandable. I'm gonna search some more, then make a new thread if needed, to see if someone with one has it working better.

I think I saw @Cobra had one somewhere.

I have a hem driver but it's for a specific UK device (Gen2)

1 Like

Guys, I am sucessfully getting 2 power readings back but I can't select both from the tiles, only the first one is selectable via ATTRIBUTE. Is anyone managing to get 2 power readings displayed in the tiles? Any ideas?

Is power 2 not being displayed as an option or do you get an error when selecting power 2? What is your reporting group selections?

If your looking to have 2 attributes in one dashboard tile, take a look at Tile Master by @bptworld. I have not finished implementing it yet, but it should do the trick.

Here is a screen shot from devices:
image
and now from tiles

So it appears the data is coming back ok. the device shows it but the tile has a problem.

Your power reading is negative. That might be a sign of misconfigured reporting groups. @codahq and myself have been working on detailed documentation, and a few minor tweaks to the driver.

Please review me new post here, and make sure the Reporting Groups are setup correctly.

Documentation and driver - Aeotec HEM (Gen 5) ZW095-A Driver

They should all be available

I'll review your documentation but in my instance negative is just fine. It's monitoring a home battery storage system, so power flows both ways depending on my PV generation and current usage.

Oh that make since. Post your reporting group selections and current states over there.

EDIT: also after you hit save preferences it will show the Reporting Group configs, c/p that on the other thread as well.

Mr stupid here but I have no idea how to select mutiple options using CTRL/COMMAND key. I use windows. I've googled it, tried various key combinations.
The normal windows method doesnt work (CTRL + click)

Just CTRL for windows it's Command on Mac. I'll update thanks!

OK.. so CTRL still doesn't work but i pumped some config data in using the Basic Z_Tool.I reloaded with the driver in your previous post and I can see them now.
I'm getting power and power 2 returned with data. I was expecting Power1/2 to be set, but what I have now is good. BTW my device has 3 CT clamps.. however I'm not using the third. I have something that seems to work so thank you very much. If you want me to do some futher testing , just ask.

Just for completeness it's £ in the UK, but again this doesnt matter as I'm not interested in this value but I bet some will be.

Wow... I didn't realise you had to save perferences before the CTRL selection method would work... so CTRL now works. Brill..

was that the very first 'save' after inclusion or something? Very odd and would like to document that if possible.

CTRL started to work after the first save preferences with your latest driver.

1 Like

Thanks I was able to recreate the issue. I will document it as well and look into a solution.

Hubitat doesn't support multi-select in drivers all the way. Ask them to support multi-select preferences in drivers.

The reason your power readings are negative is because 1 or both of your clamps are installed backwards.

I have 3 clamps, there does not seem to be any option to select the 3rd clamp? Any ideas?

Look here they are... wonder what POWER is... maybe sub of all?
image

Download the Hubitat app